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Copyright and
licence
COPYRIGHT LICENCE FOR MOODLE
The overall Moodle software package is Copyright © 1999 onwards, Martin Dougiamas with portions contributed/
copyrighted by many others (see the Developer credits and the source code itself ) and all of it is provided
under the terms of the GPL. This program is free software; you can redistribute it and/or modify it under the
terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of
the License (for Moodle 1.x), version 3 of the License (for Moodle 2.x) or (at your option) any later version.
The Moodle documentation is Copyright © 2005 onwards by the individual authors of each page (see History link on
each page at http://docs.moodle.org) and is provided to all under the same terms of the GPL as the Moodle software.
Moodle and the Moodle Documentation are distributed in the hope that they will be useful, but WITHOUT
ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
PURPOSE. See the GNU General Public License at http://www.gnu.org/licenses/gpl.html for more details.
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Creating a new
course
ADDING A COURSE
By default a regular teacher cannot add a new course. To add a new course to Moodle
you need to have either an Administrator, Manager or Course Creator role.

Adding a course
•

Go to Administration>Site Administration>Courses>Add/edit courses

Choose the category where you want your course to be.
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•

Click the “Add a new course” button

•

Enter the course settings and click the “Save changes” button.

•

On the next screen, choose the teacher to assign to the course.

Key:
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COURSE SETTINGS

General

Course full name
This is the name of the course. It is displayed as a link on course lists on the Front page and on My
home and in reports. It is also used in the browser title bar when the course is viewed.

Course short name
The short name must be unique on the site and represents the shorthand for the full name. It is used in
several places where the long name is not appropriate, such as the Navigation block. By default, only course
full names are displayed in the list of courses. However, an administrator can enable short names to be
displayed, too, by ticking the checkbox in Settings > Site administration > Appearance > Courses.

Course category
The site administrator may have created course categories to help teachers and students find
their courses easily. Course categories may be reflected in the Navigation block.

Course start date
This setting affects the display of logs and the weekly format topic dates. If you use the “Weekly” course
format, the start date will appear in the first section of the course. For example selecting 27 July, will
display “27 July - 2 August” in the first section (when default display is selected for that section).
This setting will have an effect on the display of logs. This will be the earliest possible date the log
activity will display. The setting will not affect courses using the ‘social’ or ‘topics’ formats.

••
••
••

Tip: If your institution runs on a weekly schedule, you may want to consider setting
the start date for courses on the first day of the week, like a Monday.
Tip: In general, if your course does not have a real starting date then set the date to
yesterday and use the availability setting to reveal the course to students.
Tip: See self-enrolment course settings to prevent students from entering the course before a certain date/
time.
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Visible
Here you can “hide” your course completely. It will not appear on any course listings, except for
managers, course creators, teachers and any other users with the view hidden courses capability.
Even if students try to access the course URL directly, they will not be allowed to enter.

ID number
The ID number is an alphanumeric field which can be used to match this course against an external system’s ID, as your
course catalogue ID or can be used in the certificate module as a printed field. If it is not needed, leave the field blank.

Description

Course summary
The summary appears on the course listings page. This field is searched when searching
for a course and also appears in the Course/Site description block.

Course summary files
An image (and if allowed by the administrator, other file types) may be attached to the course summary.
They will be accessible by anyone from outside of the course just like the course name or summary.
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••

Note: If summary files are not allowed by the administrator, then no upload box will appear.

Course format

Weekly format

The course is organized week by week, with a clear start date and a finish date. Moodle will create a section for each
week of your course. You can add content, forums, quizzes, and so on in the section for each week.

••
••

Tip: If you want all your students to work on the same materials at the
same time, this would be a good format to choose.
Tip: Make sure your course start date is correct. If it is not, the weeks will have the wrong date on them. This is
especially important if you are restoring a course to use with a new intake of students.
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Topics format
The course is organised into topic sections that a teacher can give titles to. Each topic section
consists of activities, resources and labels. Tip: This is great to use if your course is objective based
and each objective may take different amounts of time to complete. An example of this would
be scaffolding where the students are building upon the knowledge from earlier topics.

Social format

This format is oriented around one main forum, the social forum, which appears listed on the main
page. It is useful for situations that are more free form. They may not even be courses.
The social forum can be edited by opening the forum and clicking ‘Edit settings’ in Administration>
Forum administration. The forum introduction is displayed at the top of the course page.

SCORM format
The SCORM format only has 1 section, and allows teachers to insert a pre-built SCORM package.
Moodle can use SCORM packages as a content type (see SCORM module), or as a course format.
Note: If you have a large SCORM object you want to use as an entire course, then you can select this course
format and students will only be able to interact with the SCORM object, not the rest of the Moodle tools.
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Number of sections
This setting is only used by the ‘weekly’ and ‘topics’ course formats. In the ‘weekly’ format, the
number of sections represents the number of weeks that the course will run for, starting from
the course starting date. In the ‘topics’ format, it specifies the number of topics in the course.
Both of these translate to the number of “boxes” down the middle of the course page.

If the number of sections (weeks or topics) is changed for an existing course so that the number
is less than the number of course sections containing activities (for example the course contains
activities in 3 sections and the number or weeks/topics is set to 2) then when editing is turned on
section(s) at the bottom of the course page will be shown with the title ‘Orphaned activities’.
The number of sections (weeks or topics) may be set to 0, so that only the top general
section is displayed on the course page and there are no numbered sections.
By default, the maximum number of sections in a course is 52. An administrator can set
a different maximum number which will apply to all courses on the site.

Hidden sections
This option allows you to decide how the hidden sections in your course are displayed to students. By
default, a small area is shown (in collapsed form, usually grey) to indicate where the hidden section is,
though they still cannot actually see the hidden activities and texts. This is particularly useful in the Weekly
format, so that non-class weeks are clear, or if you have quizzes you don’t want your students to see.
Tip: If you choose, these non-available items can be completely hidden, so that students
do not even know that sections or an activity in the course are hidden.

Course layout
The Course layout setting determines whether the whole course is displayed on one page or split over several pages.
The setting applies to the topics and weekly course formats and the contributed collapsed topics course format only.
Teachers choose from the dropdown whether they wish to “show all sections on one
page” in the familiar scrolling format, or “show one section per page”.

Show one section per page
Using Weekly or Topics format it is possible to “show one section per page”
(Settings > Course administration > Edit settings).
Here is a course with four topics, the second of which is shown. The links left and right lead to
topics 1 and 3; the ‘Jump to…’ menu provides another way to move between sections:
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••
••
••
••

Tips:
The course home page shows just the section names and any text in
the section description, with the names being clickable.
If editing is ON, on the Main course page, then you will see all the content in all the sections.
There is a link at the bottom “Return to Main course page” on each single section page.

Appearance

Force theme
If the site administrator has allowed the teacher to set a course theme, this pull down menu will appear with a list of
themes on the site. Teachers can use this to choose a different look for the course from the rest of the Moodle site.

Force language
If you force a language in a course, the interface of Moodle in this course will be in the forced language,
even if a student has selected a different preferred language in his/her personal profile.

News items to show
This setting controls the numbers of news items to show in the Latest news
block. Set it to 0 and Latest news block will not appear.
The Latest News block relies on the use of the associated News Forum. News
posted in other forums do not display in the latest News block

Show gradebook to students
Many of the activities allow grades to be set. By default, the results of all grades within the course can
be seen in the Grades page, available from the main course page for students and teachers.

••

Tip: If a teacher is not interested in using grades in a course, or just wants to hide grades from students, then
they can disable the display of grades with this option. This does not prevent the teacher using or setting
grades for an individual activities, it just disables the results from being displayed to students. If grades
are used and this link is disabled, students can still see their grade from the actual activity itself, such as an
assignment.
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Show activity reports
Activity reports are available to each student. These reports or logs show their activity and
contributions in the current course. These reports include their detailed access log.
Student access to their own reports is controlled by the teacher via this course setting. For some
courses, these reports can be a useful tool for a student to reflect on their involvement and
appearance within the online environment, but for some courses, this may not be needed.
Teachers always have access to these reports via a link in the navigation block.

••

Tip: Your site administrator may ask you to turn this feature off. Showing activity reports can place a load
on the server, slowing it down at times. For large or long classes it may be more efficient to keep it off.

Files and uploads

••

This setting defines the largest size of file that can be uploaded by students in this
course. It is possible to further restrict this size through settings within each activity
module. The site administrator can determine sizes available for the teacher to select.

Tip: When uploading large files, consider that your students will need to download them to view them.

Completion tracking

••

The administrator must enable completion tracking for the site (Site administration > Advanced
features > Completion tracking) before it becomes selectable by a teacher for a course.

If Completion tracking has been enabled, the teacher will see the Activity
completion group in their course settings. However, it is possible to
track activity completion without using the Course completion feature.
It is also possible to use this feature with the Conditional activities
feature. These 3 features can be used separately or in various combinations in an activity.
Once enabled, the completion tracking settings are displayed in the completion
tracking page, and in the resource and activity settings.

Guest access
Teachers may decide to allow ‘guest’ users to access a course, including those who
have logged in “as guest” on the site log-in page. You can choose if they need
a password to enter the course or if they may enter without a password. This is
a course-level password, not a password to gain access to the Moodle site.
‘Guests’ in a course ALWAYS have “read-only” access: they cannot leave any forum posts, take quizzes
or otherwise mess up the course for real students. No user information is stored for a guest.

••

Tip: Guest access can be handy when you want to let a colleague in to look around at your work, or to let
students see a course before they have decided to enrol.
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••

Tip: You can choose between guest access with or without a password. If you choose guest
access with a password, then the guest will need to provide the password EVERY TIME they log
into the course (unlike course students). This lets you restrict your guests. If you choose to allow
access to guests without a password, then anyone can get straight into your course.

Groups
Group mode
Define the group mode at the course level by a pull down menu. The
choices are “No groups”, “Separate groups” or “Visible groups”. The
selected setting will be the default group mode for all activities defined
within that course. The group setting can affect what users see in the
Participants list and who they can interact with in activities.

Force group mode
If the group mode is “forced” at a course-level, then that particular group mode will be applied to every
activity in that course. This will override any activities that may have a special group setting.

••

Tip: The force setting is useful when the teacher wants to set up a course
and not have to change each activity’s group settings.

Default grouping
If groupings are enabled, a default grouping for course activities and resources may be set.

••

Tip: You may leave it set to “No groups” at the course level and set specific activities use groups. In this case
the ‘Force group mode’ setting should be set to “No”. For example, the teacher can use a group setting to
completely separate cohorts of students such that each group is unaware of the other in the course.

Role renaming
You can rename the roles used in your course. For example, you may wish to rename
the Teacher role as “Facilitator” or “Tutor”. These new role names will appear within
the course; for example on pages showing participants and overridden permissions.

••

Note: The site administrator or a course manager may
have changed the role names or added new roles. These names will
appear and the teacher may rename them within the course.

••

Tips: Do not worry about changing every role name. Only change the site roles which are used in your
course. For example, you may want to ignore renaming roles such as the Administrator role or the
Authenticated.
To include new role names in a course backup, users should be included in the backup.
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DELETING A COURSE

••
••
••
••
••

Only administrators and managers can delete courses. A Course creator can delete
courses they have created themselves. A regular teacher can’t delete a course.
To delete a course (administrator or manager):
Go to Administration > Site Administration > Courses > Add/edit courses
Click the course’s category (to drill down the category tree) and find the course you wish
to delete. Or use the “Search course” textbox at the bottom of the category list.
Click the “X” icon to the right of the course’s name to delete it.
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Course page and
blocks
Parts of a course homepage
Our example is of a weekly format course homepage that is the standard default for a new install on a site. There are
many course options that determine a course’s appearance and make it look very different from our examples. The
example course has a header and footer (the content of which is largely determined by a theme) and 3 columns.

Using the above image, here are the parts of a typical course homepage. It is possible to move and hide parts
of the page and different themes display blocks in different regions, so not all courses will look like this.

Left column

Centre sections

Right column

1 Course full name

2 Navigation bar

9 Login information

3 Navigation block

14 Section heading and news forum

10 ‘Turn editing on’ button

4 Administration block

15 First section – current week

11 Latest news block

5 Course administration

16 Second section – future week

12 Upcoming events block

6 ‘Switch roll to…’
7 Profile settings
8 Site administration
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Course sections
Course sections are displayed in the centre of the course page.

To edit a course section:
••Turn editing on and click the edit icon after the section title
••The number of course sections in the centre column may be changed in Settings > Course administration > Edit
settings or by clicking the plus or minus icons
at the bottom of the course page when editing is turned on.

Restrict access to a course section

••

Before this can be used the site administrator needs to enable ‘Conditional
activities’ (Settings > Site administration > Advanced features).

The ‘Restrict access’ section is then available for teachers and access to the section
(including all activities and resources within it) may be restricted.

To move a course section:
••Turn editing on.
••Click the crosshairs icon
••Drag the section to where you want to position it and let go.
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Navigation bar
The navigation bar is the row of links you will find at the top, starting at the left of your Moodle
site. It shows a user their current context path, with links to the higher contexts.
The navigation bar is sometimes referred to as ‘breadcrumbs’. This term can be confusing, since the
navigation bar does not always reflect the path followed by the user to reach the current page.

In this example of a Navigation bar, the user is in the “Pass your driving test” activity in Social
forum, in the “Driving” course, of the Miscellaneous course category in Courses.

BLOCKS
Blocks are items which may be added to the left or right or centre column of any page in
Moodle. They may also be added to the centre of the My Home (My Moodle) page. There are
39 standard blocks available in a standard Moodle 2.5 installation. Your site may have added
contributed blocks and or your site administrator may have disabled specific blocks.

••

Note: The ability to add a particular block to a page is allowed for the default role of teacher.

Blocks can be placed on the side of the screen (if your theme supports it) by using the Dock icon
Blocks can be hidden (from students and non-editing teachers) by clicking the hide icon

Default blocks
When a new course is set up, Moodle
generates the following default blocks
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Navigation block
The navigation block appears on every page of the site. It contains an expanding
tree menu which includes My Home, Site Pages, My Profile, and Courses. What
appears in the navigation block depends on the role of the user, where they
are in the Moodle site, and any settings that have been applied globally.
The navigation block has links which can be expanded or collapsed.
When logged in, a regular user will see the following as default:

My home
This takes the user directly to their personal dashboard, My home.

Site pages

This expands to show pages and resources available site
wide, for example, user blogs and a calendar. Any items
which have been added to the front page, such as resources/
activities from the Main Menu block, or the Site News will
also appear here. Other items depend on the role of the user,
so an administrator will see reports and notes, for instance.

My profile

This expands to allow regular users to view (and, if
allowed, edit) their profile, view their forum posts, view
and add and blog entries and messages and access
their private files, providing these features have been
enabled by the administrator. The administrator will
also have a link here to Notes and Activity reports.
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My courses
This takes the user to their My Home page where they see the courses they are enrolled in. An
administrator sees this link as “Courses”, which expands to the course categories.

Navigation inside a course
The image on the left shows the navigation block inside a course,
showing Current courses, My courses and (all) Courses.

Current course
When user is in a course, this link expands to show each section of the
current course and any activities/resources which are in that section.

My courses
When a non-admin user clicks this link in a course, it takes them to their
My home page where they will see other courses they are enrolled in.

Courses

••

••

If the administrator has enabled “show all courses” in
Settings>Site administration>Appearance>Navigation,
then clicking on this link in a course will take the
user to the courses index page course/index.php.
An administrator can change navigation settings, such as the
default home page, and whether to show course categories in the
navigation, in Settings > Site administration > Appearance > Navigation.

Courses block

••

Note: The Navigation block includes a list of all courses a user is enrolled
in. However, a teacher can add the Courses block.
The Course block lists and allows navigation between all of the courses
in which the logged in user is enrolled in. The block title shows as
“My courses” and allows one-click access to a course’s home page.
There is a also the option to list All courses... available within the
Moodle site. This will display a list of course types and a click
on one of the types will reveal all the courses in that category.
There is also a search all courses option on this page.
A brand new user to a Moodle site, who has not enrolled in
any course, will see the block title as “Course Categories”.
When a student enters an unassigned course using
the course block, they will be asked to enroll.
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Site administration settings

••

The courses block has some settings which may be changed by an administrator
in Settings > Site administration > Plugins > Blocks > Course list.

Administration block
The Administration block provides context-sensitive links to settings pages.
What appears in the Administration block depends upon the Context (Page being shown and user’s permissions).
For example, a site administrator on the front page will have Front page settings while a teacher in a course will
have more options in Course administration than a student. Here are examples of the Administration block:

Admin view from Front page (collapsed)

Teacher view in a course (expanded)

Student view in a course (collapsed)
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Latest news block
Recent posts made in the News forum are displayed in the
Latest news block, along with a link to older archived news.

••

Tip: By default, the Latest news block displays 3 news items.
This may be changed in Settings >
Course administration > Edit settings.

Upcoming events block
The Upcoming events block displays future events in a summarized list.

••
••

The number of days in advance is determined by the calendar_
lookahead setting in Site Administration > Appearance > Calendar.
Note: It seems the look-ahead has a setting in Preference
on the user page when logged in. This setting, when logged
in, seems to over-ride the setting described above. It is
not clear if there is a way to extend Calendar > Preference
look-ahead setting, beyond the 20 days that it offers.
Events are generated directly from the calendar and/or activity
deadlines, providing a link to full details or directly to the activity.
There are also links to Go to calendar... and add a New Event....

••If you click on a date, you will go to the day-view calendar for that day.
••If the title of the event is a link, and you click on it, you will be taken to that event.

Calendar block
The Calendar block displays the following events:
•• Site (event viewable in all courses - created by admin users)
•• Course (event viewable only to course members
- created by teachers)
•• Groups (event viewable only by members of a group
- created by teachers)
•• User (personal event a student user can create
- viewable only by the user)
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Recent activity block
You know that game where everybody except one leaves a room, the person who’s left changes
just one thing, then everybody comes back and has to spot the thing that changed?
Enabling the Recent Activity Block will show participants updates since they last accessed the course.

Without this block, (unless you go out of your way to notify them) students
and colleagues are prone to miss the changes you make e.g. modifications or
additions, because they don’t have an exact memory of that course as they last
left it and because they have no way of knowing when to look for a change.
The Recent Activity Block can relieve a lot of anxiety in students
who are worried about missing something important.
The Recent activity block lists course activity, such as updated
resources and activities, forum posts and assignment
submissions, since the user last accessed the course.

Full report of recent activity
A full report of recent activity can be accessed via a link in the recent activity block. This will
lead to a screen which has a time filter and organizes activity by course sections.

The advanced search button or link has more filter options. These include selecting all or a
specific: participant, activity, since date. It also allows the list to be sorted in course order, oldest
to recent or recent to oldest date. There is a link to return to the Normal search screen.
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••

Site administration setting

The setting assignment_showrecentsubmissions in Settings > Site administration > Plugins > Activity modules
> Assignment determines whether students can see other students’ recent assignment submissions or not.
Teachers can always see all recent submissions and students can always see their own recent submissions.

Adding a block to a page
To add blocks, turn editing on and use the ‘Add a block’ drop-down menu

To move a block
Drag and drop
Ensure editing is turned on then click onto the block
title until the crosshair icon appears
While keeping the block selected, drag it to where
you want to position it and let go.

Alternative method
Click on the up/down arrow
Click on the place holder (a zone with a dashed border)
where you want the block to appear.

Block configuration
After adding a block, click the edit icon in the block header to configure it.

Block settings

Certain blocks, such as the
HTML block, allow a block
title and more to be set.
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Where this block appears
Depending upon the context
and users permissions, this
area determines where
this block will appear.

••Original block location: provides information about where the block was initially created.
••Display on page types: allows the user to set the context that the block can appear in. These options will vary
depending upon the permissions of the user. For example a site administrator might see a setting that will allow the
block to appear on Any page, or any type of course main page, while a teacher may only see the option to place it on
every page in the course.
••Default region: Usually a right column or left column option
••Default weight: Where in the column do you want it to appear if there are other blocks in that column. -10 will put it at
the top, 10 will put it at the bottom. A zero is neutral.

On this page
•• Visible - Yes or No.
•• Region - Here you can override the column preference
on this page.
•• Weight - Here you can override the default setting on this page.

‘STICKY BLOCKS’
The term ‘sticky’ block was used in older versions of Moodle to mean blocks which the admin added
either site-wide or to the My home page and which could not be deleted by regular users. Although the
term is no longer used, it is still possible to make blocks ‘sticky’ and in a wider variety of locations.

••

In Moodle 2.4.2 onwards, if an admin deletes a “sticky” block in a course, they receive
a warning of the site-wide consequences of this action before it is deleted.

Making a block sticky throughout the whole site
The Moodle administrator might wish for example to display support contact
details site wide using an HTML block called ‘Helpdesk’:

•• As an administrator,
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turn on the editing on the front page and add the block you wish to make sticky.
••For Where this block appears > Page contexts, choose ‘Display throughout the entire site’.
••Decide other settings according to your preference and save.
••The block will now appear on all pages of your site.

Making a block sticky throughout a course
The teacher might wish for example to display the Messages block everywhere in the course. This
would allow students easily to message each other and their tutors not only on the course from the
main page but also on individual activities. The block would be available on admin pages too.
•• As a teacher in the course, turn on the editing
on the course main page and add the block you
wish to make sticky.
•• For Display on page types, choose ‘Any page’
•• Decide other settings according to your
preferences and save.
•• The block will now appear on all pages of the
course.

Making a block sticky in a resource or an activity
A teacher might wish to display a block in one particular resource or activity, for example a Head of Faculty might
make create a Book for departmental policies and wish to add the comments block to every chapter/page of a book so
colleagues can give quick feedback. (Note that such a comments block would be the same block on each chapter/page)
•• As a teacher in the course, turn on the
editing and click into the resource/activity
-in this case a Book and add the block.
•• For Display on page types, you will see
(for example) ‘mod-book*’
•• Decide other settings according to your
preferences and save.
•• The block will now appear on all related
screens.

BLOCK PERMISSIONS
To change role permissions for a block
••

Turn editing on in the course

••

Click the Assign roles icon (a face and mask) in the header of the block

••
In the administration block, go to Block administration > Permissions
(ignore the message ‘You are not able to assign any roles here’, which is to be
expected, since roles are not generally assigned in the block context)
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ACTIVITIES AND RESOURCES

To add an activity or resource to the course
•• Turn on the editing by clicking the button
top right or the link in Administration > Course
administration.
•• Click ‘Add an activity or resource’ to open the new
activity chooser. Select an activity or resource then
click the Add button, or simply double-click on the
activity or resource name.
If desired, the activity chooser can be switched
off via Administration > Course administration
> Activity chooser off. Activities and resources
can then be added using dropdown menus. (The
setting appears only when editing is turned on.)

••

Note: The Moodle admin can switch this off
by default in Administration > Site administration
> Appearance > AJAX and Javascript.

Adding resources and activities using drag and drop
••To add a file, simply drag and drop it onto the course section where you’d like it to appear
••To add a folder of files, simply zip the folder then drag and drop it onto the course section where you’d like it to
appear, answer ‘Unzip files and create folder’ to the popup dialogue, then click the upload button
••To add a SCORM package, simply drag and drop it onto the course section where you’d like it to appear, answer ‘Add a
SCORM package’ to the popup dialogue, then click the upload button

Conditional activities and Restricting access
Conditional activities enable teachers to restrict the availability of any activity or course section (in Moodle
2.3 onwards) according to certain conditions such as dates, grade obtained, or activity completion.

••

To use conditional activities, the feature must be enabled by an administrator by checking
the enable availability box in Settings > Site administration > Advanced features.

When enabled by the administrator, a “Restrict access” setting appears in the settings
of activities or resources and also when editing a course section.
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Restricting access to course sections
It is possible to restrict access to activities within a whole course section by
specifying the conditions in the settings for that particular section.

••

Note: For more detailed information, see the section on Conditional activities and Restricting access

EDITING ELEMENTS ON YOUR COURSE HOMEPAGE
With the editing turned on, each item on your course homepage and each section or block will have
icons next to it which all perform different functions such as edit, move, copy, delete, hide.

••

Note: Your theme may have icons different from these below:

Use the pencil icon to rename your item directly on the course page without entering the settings for that
item.

The edit icon allows you to change the wording or settings of the item.

The duplicate icon allows you to copy an activity or resource within your course
The open-eye icon means an item is visible to students. It will close when you click on it

The strike-through eye icon means an item is hidden from students. It will open when you click on it

The right arrow icon is used to indent course elements (there is also a left icon)

The move icon allows you to move items or sections by dragging and dropping.

This move icon appears if you don’t have Ajax enabled.
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The move-here icon appears when moving a course element
without Ajax. Click into the box to re-locate your item.

The up/down arrows allow you to move course sections up or down and appear if you do not have Ajax
enabled.

The delete icon will permanently delete something from the course

The groups icon allows you to change between no groups or separate/visible groups

The roles icon allows you to assign roles locally in the item.

••

The highlight icon only applies to course sections. It allows you to highlight a section as current.

Tip: Activity and resource descriptions can be displayed on the course page just below the link to the activity
or resource by clicking the ‘Display description on course page’ checkbox in the activity or resource settings.
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The text editor
The text editor (sometimes referred to as the ‘HTML editor’ or even ‘TinyMCE’) has many icons to assist
the user in entering content. Many of these icons and functions should be familiar to anyone who uses a
word processor. Some examples of where you will see the text editor include: Editing Section headings,
description of an activity, writing an answer to a quiz question or editing the content of many blocks.

Collapsed editor
Since Moodle 2.5, the text editor appears collapsed with no formatting in many places to save
space. To access the full editor, click “Show editing tools” as in (1) in the screenshot below. You
can use keyboard shortcuts for quick formatting as in (2) in the screenshot below.

To increase the size of the editor, drag the bottom right once you have clicked
“Show editing tools” as in (3) in the screenshot below.
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THE FULL EDITOR

Standard version of text editor toolbar

List of groups
For those who are not familiar with the tool bar, here are the functions listed by group using the
above example. Remember that the site administrator can edit or provide additional toolbars.

Row 1
- Font, size and heading group
- Undo and Redo group
- Find and Replace group
- Full screen toggle

Row 2
- Text effect group
- Line format group
- Formatting group
- Color group
- Paragraph group

Row 3
- Number and Bullets and indents
- Link group
- Insert group
- HTML source toggle and spellchecker (IE 9/8 only)
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SPECIAL FEATURES

Insert images and media

The Insert images and media group

32

1
2
3
4

Insert Image - uses File picker
Insert Emoticon
Insert Media - uses File picker
Insert Equation - uses java script editor

5
6

Insert Non breaking space
Insert Custom character - Special keyboard characters
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7

Insert Table
General tab

Advanced tab

To add borders to a table
Cell borders are crucial for helping readers to follow the rows across the screen.
If they aren’t showing already you can add them as follows:
••In the Wiki page containing your table, click its Edit tab
••Carefully select all the cells of the table
••Then right click (Macs: Command+click or Ctrl+Click) over any part of your selection to get a context menu; from it
select Cell > Table Cell Properties; the cell properties dialog box then loads.
••Click on its Advanced tab, set Border Color to black (for instance), then click Apply, and then click Update.
••Click Save; the Wiki page containing your table will then load displaying its borders.
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Label
resource
A label serves as a spacer on a Moodle course page. It can be used to add text, images, multimedia
or code in between other resources in the different sections. It is a very versatile resource and
can help to improve the appearance of a course if used thoughtfully. Banners or descriptions
may be added to labels to distinguish between and highlight different areas.
On the other hand, over-use of multimedia (sound, video) in labels can slow down the loading of a course page.
Example of a label with an embedded mp3 file
Text, images and URLs can be embedded
into labels by drag and drop.

ADDING A LABEL
With the editing turned on to a course by choosing Label from the “Add an activity or resource”
link (or, if not present, the “Add a resource” drop down menu) in the section where you want
to add your menu. Click “Expand all” top right to see all the settings expanded.

General
Collapsed view of the editor

Click to display
editing tools; drag
bottom right corner
to enlarge the editor
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Type your chosen words or add your resources.

••

Note: Because the label has the TinyMCE text editor, it is possible not just to type words
but also to add images, links, media or code from within the labels’ editor.

Common module settings
Leave Common Module settings as “show” for the label to be visible.

Restrict access/Activity completion
These settings are visible if Conditional activities and Activity completion have been enabled in the site and the course.
Click “Save and return to course”.
You can now use the move icon (crosshair or up/down arrow) to move your label to where you wish it to display.

ADDING IMAGES TO A LABEL

Drag and drop images

••
••

Note: this does not work with IE 9, Safari 6 or below or earlier versions of Firefox.
Media drag and drop must be enabled in Administration > Site
administration > Plugins > Activity modules > Label

With the editing turned on, drag your image
into the section you want it to appear.

In the box that follows, choose “add image”
It will appear embedded in a label.
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Conventional method
Follow the instructions for adding a label.

Click the image icon in the text editor.

Click “Find or upload an image”. Choose and upload your image using the filepicker.
Leave Common module settings at “show” if you wish the label to be visible
Click “Save and return to course”

ADDING TEXT TO A LABEL

Conventional method
As the label uses the Text editor it is straightforward to enter text and other required symbols
and equations. It is however possible also to drag and drop text directly into a label.

Drag and drop text

••
••

Note: this does not work with IE, Safari 6 or below and is unreliable with Firefox.
Drag and drop upload of text/links must be enabled in Administration > Site
administration > Development > Experimental > Experimental settings

Select the text
you wish to use,
for example in a
Word document.

With the editing
turned on, drag
the text over to
the section you
want it to appear.
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From the box that appears, choose
“add a label” and then “upload”.

And the text appears in the label

ADDING A LINK TO A LABEL

Conventional method
As the label uses the Text editor it is straightforward to click the “link” icon and enter your
linked URL. It is however possible also to drag and drop links directly into a label.

Drag and drop links

••
••

Note: this does not work with IE, Safari 6 or below and is unreliable with Firefox
Drag and drop upload of text/links must be enabled in Administration > Site
administration > Development > Experimental > Experimental settings

Open up a new window with the URL you wish to link to. Select the link in the browser bar.
With the editing turned on, drag the URL over to the section you want it to appear.
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From the box that appears, name the link and then click “upload”.

The named URL link appears in the label

ADDING SOUND OR VIDEO TO A LABEL
If multimedia filters are enabled, a label is a neat way of displaying sound or video in an inline player on the course page.
Follow the instructions for adding a label.

Click the media icon in the text editor.

Click “Find or upload an sound, video or applet”
Choose and upload your sound or video file using the file picker.

••

Note: You can search YouTube for a video to embed if your admin has enabled the YouTube repository.

Leave Common module settings at “show” if you wish the label to be visible.
Click “Save and return to course”
]
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ADDING CODE TO A LABEL
An example of this is the ability to embed a Google map into a label.
Follow the instructions for adding a label.

Click the HTML icon in the text editor.

This brings up the screen in code (HTML) view.

Paste the code you grabbed from
Google maps into this screen
Scroll down and click “Update”

Leave Common module settings at “show”
if you wish the label to be visible.
Click “Save and return to course”

••

Note: The success in adding code to
a label depends both on the type of code
and the permissions of the user.
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File resource
When you wish to share with your students a simple file such as a Word-processed document
or slideshow (e.g. created in MS Word, PowerPoint, or Open Office) you use the file resource
type. It allows you to upload and display a variety of resources on your course.

How your students access them depends on your
choices in File resource settings. Note also that they
will only be able to open your files if they have the
appropriate software on their own computers.

ADDING A FILE

Quick method

••

Note: Does not work with Internet Explorer 9 or lower

Click the ‘Turn editing on’ button at the top right of the course page

Drag and drop the file onto the course section
where you’d like it to appear
If necessary, edit the title of the file by clicking the pencil icon,
or edit other options (see left) by clicking the editing icon.
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LONGER METHOD
Click the ‘Turn editing on’ button at the top right of the course page. Click ‘Add an activity or resource’ link, then
in the activity chooser, select file then click the Add button (or select file from the “Add a resource” dropdown
menu). All settings may expanded by clicking the “Expand all” link top right. Select your options as below:

General
Name
Whatever you type here will form the
link learners click. So it is helpful to give
it a name that suggests its purpose.

Description
Add a description of your file here if desired.
Click “Show editing tools” to display the
rich text editor, and drag the bottom
right of the text box out to expand it.

Display description on the course page
If this box is ticked, the description
will appear on the course page just
below the name of the file.

Content
Either drag and drop your file onto the
arrow if you are using an appropriate
browser, or click on “Add” and use the
File picker to upload your file.

••

Note: if legacy files were used there will
be a setting “Migration of old course file”

Appearance
Display
•• Automatic - Make the best guess at what should happen (probably what is
wanted 99% of the time).
•• Embed - Show the Moodle page with heading, blocks and footer. Show the title/
description of the item and display the file directly in the page as well (good for
images, flash animations, videos?, PDFs).
•• Force download - user clicks on the file, then the web browser pops up with the
‘where do you want to save this file’ box.
•• Open - No Moodle heading, blocks, footer or description - just show the file in the
web browser (e.g. shows image, PDF, flash animation, taking up the whole browser
window)
•• In pop-up - Same as ‘Open’, but opens a new browser window to show this file
(without the Moodle heading, blocks, etc) - this browser window also does not have
all the menus and address bar in it.
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••

The following additional options are only there if you enable them via
Site administration > Plugins > Activity modules > File:

••In frame - show the Moodle heading and the file description, with the file displayed in a resizable area below
(images, PDF, flash, etc. supported).
••New window - very much like ‘in pop-up’, but the new window is a full browser window, with menus and address bar,
etc.
All of the above is true of items that can be displayed inside the browser directly (e.g. images, text files,
PDFs (with plugin)). If the file cannot be displayed within the browser (e.g. word documents, without
a suitable plugin, or other files that need to be loaded by an external program), then the pop-ups or
frames, etc. will be created, but then the browser will take over and ask if you want to save the file.
To summarise:
••Do you want Moodle to sort it all out for you? - Automatic
••Do you want to force the user to save the file (or open it in a program on their desktop)? - Force download
••Do you want to show the file as part of the Moodle page (images, PDFs, videos)? - Embed
••Do you want to show the file in the browser, but without the Moodle page decorations (images, PDFs, videos)? Open
••Do you want that, but in a new window? - In Pop-up (or possibly ‘New window’)
••Do you want to use a horrible bit of non-strict HTML that should never be allowed in polite company? - In frame

Show size/type
To show the file size and/or type on the course page and also on the
resource page, simply tick the appropriate checkboxes.

Display resource name/description
To show the resource name and/or description when clicking to access the file, simply tick the appropriate checkboxes.

Pop-up width/height
(This setting is visible when “Show more” is clicked.) If your file is to be
displayed in a pop-up, specify the width and height here.

Use filters on file content
(This setting is visible when “Show more” is clicked.) If you wish included media, such as images and
mp3, to appear embedded in the files then select “all files” or “HTML files only”, according to your
file types. (Note that this setting may cause problems for some Flash and Java applets.)

Common module settings
See Common module settings

Restrict access/Activity completion
These settings are visible if Conditional activities and Activity completion have been enabled in the site and the course.
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Displaying a website index page

Setting the main file
The file module may be used if you have a folder with
linked files such as a website with an index.html file
or a flash activity with xml/swf and index file.

Website index page set as main file
Click the ‘Turn editing on’ button at the top right of the course page
Drag and drop the zipped folder onto the course section where you’d like it to appear,
answer ‘Create file resource’ to the popup dialogue, then click the upload button
Clicking the editing icon (hand with a pen) then click on the zip file and unzip it
Click on the index.html file or the file you want to start displaying your linked files from then in the
popup dialogue click the button ‘Set main file’. This ensures this file is the one that appears on the
course page for students to click on. The main file is then indicated with a title in bold.
Click the button ‘Save and display’ at the bottom of the page.
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SITE ADMINISTRATION SETTINGS

••

The file module has additional settings which may be changed by an administrator
in Settings > Site administration > Plugins > Activity modules > File.

Frame height
Here you can specify the height of the top frame (containing the navigation) if you choose
the “in frame” display option. Note: If your theme has a large header then the resource_
framesize variable should be increased to prevent horizontal and vertical scrollbars.

Require activity description
This setting allows you to turn off the requirement for users to type something into the description box.

Available display options
This setting allows you to add different ways the resource may be displayed on the course
page. By default Moodle doesn’t enable “New window” or “In frame”, so you need to set them
available here if required, and you can also disable other options if not applicable.

Default values for activity settings
Here you can set the defaults for this resource. You can also choose which setting(s) to class as
“Advanced”. These settings will only then appear if the user clicks “Show More” in the settings.
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Folder
resource
A folder allows a teacher to display several course resources together. The resources may
be of different types and they may be uploaded in one go, as a zipped folder which is then
unzipped, or they may be added one at a time to an empty folder on the course page.

Using a folder to display resources is neater than displaying files
one by one in a list. It takes up less space on the course page.
The downside is that at present you are forced to download files stored
in a folder resource. You cannot have (for example) a folder of pictures
where the user can view the pictures in Moodle without a download.

ADDING A FOLDER TO A COURSE

••

Note: Folders you wish to upload to Moodle have to be “zipped” or “compressed” first.
The way you do this depends on your computer and operating system.

If you already have a folder of files you would like to display, there are two methods:

Quick method
Click the ‘Turn editing on’ button at the top right of the course page
Drag and drop the folder
onto the course section
where you’d like it to appear

Click the button of the action you would like to take
with the folder (in our case, “Unzip”) and click “Upload”
If necessary, edit the title of the folder
by clicking the pencil icon
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Longer method
Click the ‘Turn editing on’ button at the top right of the course page
Click ‘Add an activity or resource’ link, then in the activity chooser; select folder then click the “Add” button (or select
folder from the “Add a resource” dropdown menu). All settings may expanded by clicking the “Expand all” link top right.

General settings
Add name and a description (which may be required
or optional according to the admin settings). Click
“Show editing tools” to display the rich text editor
and drag the bottom right of the text box out to
expand it. Enabling ‘Display description on course
page’ will show it just below the link to the folder.

For Content
Either drag and drop a zipped/compressed folder into the box with an arrow or click the Add button
to open the File picker menu in order to choose a file from your computer or a repository.

When the folder thumbnail appears,
click on it and select “Unzip”:
Click the original (zipped) folder and click
the “Delete” button to delete it if you wish
Select how you want to display your
folder contents, your Common module
settings and, if enabled, Conditional
activities settings and Activity completion
and click “Save and return to course”

Click the button ‘Save and return to course’ at the bottom of the page
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CREATING AND UPLOADING TO A NEW FOLDER
Use this method if you want to create a folder on your Moodle course and then upload files into it.
Click the ‘Turn editing on’ button at the top right of the course page
Click ‘Add an activity or resource’ link, then in the activity chooser; select folder then click
the “Add” button (or select folder from the “Add a resource” dropdown menu)
Enter a name and a description (which may be required or optional according to the admin settings)
Click the “Create folder” link
as as shown on the left.
Choose a name for your new folder
and then click “Create folder”
[

Click INTO the folder

You can then add individual files into the folder either by
dragging and dropping into the box (1 to the left) or clicking
the “Add” (2 to the left) to upload files from the File picker

Choose how you want to display your folder contents, your Common module
settings and, if enabled, Conditional activities settings
Click “Save and return to course”
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File
picker
The file picker enables files to be selected and displayed in Moodle - for example, when an editing teacher
clicks Add an activity or resource > File, or when a forum participant adds an attachment to a post.

Usually the file is copied into Moodle from wherever you have chosen it from (e.g. a repository
or your computer), though for some repositories, such as the YouTube videos repository,
a link is created, and in some situations an alias or shortcut may be created.
An “add” button appears which is clicked on to access the file picker:

GETTING FILES FROM THE FILE PICKER
When the file picker screen appears, a number of links are listed down the side. These are
links to Repositories which hold files you might want to use. There is also a link Upload
a file which you would click on to add a file yourself from your computer.

••

Which repositories are included depends on which ones have been enabled by the administrator
and also the context in which you access the file picker. For example, if you have reached the
file picker by clicking on the media icon in the TinyMCE text editor then you might see the
Youtube videos repository link. If you have reached the file picker by clicking on the image
icon in the TinyMCE text editor then you might see the Flickr repository repository link.

••

Note: The order in which repositories are listed in the file picker is set by an administrator
in Settings > Site administration > Plugins > Repositories > Manage repositories.
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VIEWING FILES IN THE FILE PICKER
There are three ways to view files in the File picker, depending on your personal preference.

View as icons
This shows the files as easily identifiable thumbnails:

View as table
This shows the files with details such as licence, date uploaded, size etc:

View as a list
This shows the files in a hierarchical list:
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Page
resource
A page resource creates a link to a screen that displays the content created by the teacher.
The robust Text editor allows the page to display many different kinds of content such as
plain text, images, audio, video, embedded code or a combination of all these.

ADDING A NEW PAGE TO YOUR COURSE
From the the “Add an activity or resource” link (or, if not present, the “Add a resource” drop down
menu),choose Page All settings may expanded by clicking the “Expand all” link top right.
In the “Adding a new page” screen that follows, give your page a name and a description
(which may or may not be required according to admin settings)
Add your content to the Page content section.

General
Name
Whatever you type here will form
the link learners click on to view
the page so it is helpful to give it
a name that suggests its purpose.

Description
Add a description of your page
here. Click “Show editing tools”
to display the rich text editor,
and drag the bottom right of
the text box out to expand it.

Display description on the course page
If this box is ticked, the description will appear on the course page just below the name of the page.

Content
Add your page
content here. You
can use the features
of the Text editor to
add media, images,
links and more.
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Appearance
Choose here whether or not to display the page
name and/or description along with the page
content when a user clicks on the page.

••

If the administrator has allowed both ‘open’
and ‘pop-up’ as display options (from Administration>Site
administration>Plugins>Activity modules>Page),
you will have additional display settings here.

Common module settings
See Common module settings

Restrict access/Activity completion
These settings are visible if Conditional activities and Activity completion have been enabled in the site and the course.

SITE ADMINISTRATION SETTINGS
The page module has additional settings which may be changed by an administrator in
Administration > Site administration > Plugins > Activity modules > Page.

••
••
••

Require activity description

This setting allows you to turn off the requirement for users to type something into the description box.

Available display options

This setting allows you to add different ways the resource may be displayed on the course page.

Default values for activity settings

Here you can set the defaults for this resource. You can also choose which setting(s) to class as
“Advanced”. These settings will only then appear if the user clicks “Show advanced” in the settings.

WHY A PAGE AND NOT A FILE?
Opens seamlessly - no clunky attempts to launch third party software (e.g.
Microsoft Word) which some users may not be able to access.
Can be accessed by mobile devices e.g. smartphones (again, not all
smartphones can handle word-processed documents)
Much easier for the Teacher to edit (i.e. saves time)
Much more accessible, and readily configurable for reading (easier to
resize text, change colours, etc, in the web browser)
Can contain links - e.g. to files, to web pages, or to Glossary entries
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Use a page if:
The document doesn’t need to be printed
You need to update it fairly often
You don’t need to impose strict control over the way it looks (for accessibility
reasons you should, if educationally appropriate, avoid taking control)
Your students may need to refer to it (on their smartphone for example) frequently
for reference e.g. timetable, schedule, tutorial groups, reading list.

HOW TO CREATE A PAGE

Typing directly into the Editor
See Page module settings.

Drag and drop text into a page
It’s possible to select text from a website or a word processed document and create a page by drag and drop.

••
••

Note: this does not work with IE, Safari 6 or below and is unreliable with Firefox
Drag and drop upload of text/links must be enabled in Administration > Site
administration > Development > Experimental > Experimental settings

Select the text you wish to use, for example in a Word document. Note: Pasting from MS
Word is fraught with danger. See #Pasting from another document below.

With the editing turned on, drag the text over to the section you want it to appear.
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From the box that appears, choose
“Create a new page resource”
Give it a name and then click “upload”.

The page is created

View of the page

Pasting from another document
To safeguard against unpredictable, ugly, and inaccessible results, it’s important to take some easy extra
steps when pasting word processed and other text into web authoring software including Moodle.
Open the document containing the text you want to paste into your new Page, and copy that text ready to paste.
When you are ready to paste the content into Moodle, you have two options:

Keeping the original formatting
••Click the Paste From Word icon. A pane loads containing an empty text field and you can press your keyboard’s
Control + V keys to paste what you copied into the text field. Then click the Insert button; your text appears and can be
edited within learn.gold.

••

Note: if the original formatting does not conform to Web accessibility requirements, it won’t be transferred.

Stripping out the formatting
Copy the text ready to paste and:
••Do not click the Paste From Word icon.
••Instead click the Paste As Plain Text icon and proceed to paste directly.
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Book
resource
The Book module makes it easy to create multi-page resources with a book-like format.
Previously created websites can be imported directly into the Book module. Books can be printed entirely or by chapter.
The book module allows you to have main chapters and sub chapters, but it goes
no deeper. In other words, sub chapters cannot have their own sub chapters, as the
module is intended to be a simple resource for teachers and students.
The book module is not interactive. You can, however, link to choices, forums etc., from within
a book. Also, Flash movies and other multimedia may be included in a book

ADDING A BOOK
A teacher can add a book by choosing it from the “Add an activity or resource” link (or, if not present, the “Add a
resource” drop down menu in course.) All settings may expanded by clicking the “Expand all” link top right.

General
Name
Use a descriptive name for your book as it will
form the link the students will click on to access it.

Description
Provide information for your students
here so they are clear what the book is
about. Click “Show editing tools” to display
the rich text editor and drag the bottom
right of the text box out to expand it.

Display description on course page
Enabling this will display the description on the course page just below the link to the book.

Appearance
Chapter formatting - options:
•• None - chapter and subchapter titles are not
formatted at all, use if you want to define special
numbering styles. For example letters: in chapter title
type “A First Chapter”, “A.1 Some Subchapter”,...
•• Numbers - chapters and subchapters are
numbered (1, 1.1, 1.2, 2, ...)
••Bullets - subchapters are indented and displayed with bullets.
••Indented - subchapters are indented.

54

Key:

Teacher view

Student view

Admin setting

Tip

Custom titles
If you disallow custom titles, the chapter title (the one that appears on the table of contents) will
appear as a header at the top of your content (1 below) If you enable custom titles, you will be able
to create a title different from the one that appears in the ToC or display no title at all (2 below) If you
enable custom titles, you will need to enter the chapter title as part of the page content.

Common module settings
See Common module settings

Restrict access/Activity completion
These settings are visible if Conditional activities and Activity completion have been enabled in the site and the course.

••

Site administration settings

The administrator can set the default values for chapter formatting, the available options for chapter numbering and
whether or not to require a description from Administration > Site administration > Plugins > Activity modules > Book.

Adding chapters and subchapters
Titles of chapters appear as links in the table of contents to the left of your content. Keep your titles short.

To add another chapter, click on the red cross in the Table of Contents
or first chapter. The new chapter will be inserted directly after the
chapter whose title is on the same line as the red cross you click

Note that the sub chapter box is checked. A chapter
may have many sub chapters, but sub chapters
cannot have subchapters. In order to keep this
resource simple, you are limited to two levels.
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You now see a chapter and a sub chapter. Because we did not elect to number chapters,
the fact that the second chapter is a sub chapter cannot be seen in the table of contents.
Note that you do, however, see this in the title above the content.
By the way, the items in the table of contents are neither numbered
nor are they indented only because that is the option we chose when
setting up the book. We can always go back and change that.

Importing chapters
To import chapters:
••Create a zip file of HTML files and optional multimedia files and folders.
••If you wish to upload subchapters, add “_sub” to the end of HTML file or folder names.
••Go to Administration > Book administration > Import chapter
••Choose whether each HTML file or folder represents one chapter
••Browse for and select the zip file, either using the Add button or the drag and drop method:
••Click the import button

••

Note: Relative file links are converted to absolute chapter links. Images, Flash and Java are
re-linked too. Remember to upload images and multimedia files as well as HTML files.
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URL resource
ADDING A URL RESOURCE TO YOUR COURSE
Turn editing on.
From the “Add an activity or resource” link (or, if not present, the “Add a resource” drop down
menu), choose URL. All settings may expanded by clicking the “Expand all” link top right.

General
Name
Whatever you type here will form
the link learners click on to view
the URL so it is helpful to give it a
name that suggests its purpose.

Description
Add a description of your page
here. Click “Show editing tools”
to display the rich text editor,
and drag the bottom right of
the text box out to expand it.

Display description on the course page
If this box is ticked, the description will appear on the course page just below the name of the URL.

Content
Either enter the URL in the
external URL field.
Or click the “Choose a link” button to
open the file picker and choose a URL
YouTube, Picasa etc (depending on which
repositories are enabled for the site.
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Appearance
Display
•• Automatic - Make the best guess at what should happen (probably
what is wanted 99% of the time).
•• Embed - Show the Moodle page with heading, blocks and footer.
Show the title/description of the item and display the file directly in the
page as well
•• Open - No Moodle heading, blocks, footer or description - just show
the file in the web browser (e.g. shows image, PDF, flash animation,
taking up the whole browser window)
•• In pop-up - Same as ‘Open’, but opens a new browser window to show
this file (without the Moodle heading, blocks, etc) - this browser window
also does not have all the menus and address bar in it.
The above options are the default display options.

••

Tip: Additional display options may be enabled by an administrator in
Site administration > Plugins > Activity modules > URL.

Pop-up width/height
If your URL is to be displayed in a pop-up, specify the width and height here.

Display URL name/description
To show the resource name and/or description when clicking to access the URL, simply tick the appropriate checkboxes.

URL variables
This section allows you to pass internal information as part of the URL.

This is useful if the URL is actually an interactive web page that takes parameters, and
you want to pass something like the name of the current user, for example.

Common module settings
See Common module settings

Restrict access/Activity completion
These settings are visible if Conditional activities and Activity completion have been enabled in the site and the course.
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Drag and Drop a URL

••

If an administrator has enabled the experimental feature ‘Drag and drop upload of text/links’ in
Settings > Site administration > Development > Experimental > Experimental settings, a link can
be dragged into a section of the course and given a name, as shown in the images below.

Site administration settings

••

The URL module has additional settings which may be changed by an administrator
in Administration > Site administration > Plugins > Activity modules > URL.

Frame height
Here you can specify the height of the top frame (containing the navigation) if you
choose the “in frame” display option. Note: If your theme has a large header then the
height should be increased to prevent horizontal and vertical scrollbars.

Require activity description
This setting allows you to turn off the requirement for users to type something into the description box.

Password
Here you can add a password that will connect your users to a secure site.
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Available display options
This setting allows you to add different ways the resource may
be displayed on the course page. There are a number of defaults
but you can add or change them here. Other display options are:
••In frame - show the Moodle heading and the file description,
with the file displayed in a resizeable area below
••New window - very much like ‘in pop-up’, but the new window
is a full browser window, with menus and address bar, etc.

Default values for activity settings
Here you can set the defaults for this resource. You can also choose which setting(s) to class as
“Advanced”. These settings will only then appear if the user clicks “Show advanced” in the settings.
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Assignment activity
ADDING AN ASSIGNMENT
To add a new Assignment activity to your course, login with the appropriate access
rights (e.g. editing teacher, course creator or administrator) and Turn Editing On. Within
the required Week or Topic Block click Add and Activity or Resource link.
••In the Add an activity or resource dialogue box that appears, select Assignment and click Add.
••To edit an existing Assignment activity, login to your course with the appropriate access rights (e.g. editing teacher,
course creator or administrator) and Turn Editing On. Select the Update icon against the relevant Assignment item.
Alternatively, simply click on the name of the Assignment activity you wish to edit and then
click the Edit Settings link under Assignment administration within the Settings block.

CONFIGURATION OPTIONS
The following configuration options are available when creating or editing/updating any Assignment
activity. Only General, Availability and Submission types are open by default;the others are collapsed. To
expand everything, click the “Expand all” link top right. Click on any screenshot to see it full size.

General
The General section allows you to give your assignment a name and description.

Assignment name
Give your Assignment a name (e.g. “Report on Topic 1 Content”). The title entered here will
be the name that learners see in the course content area. Learners will click on this name
to view the details of the assignment and, if applicable, submit their work.

Description
Provide instructions for your students here so they are clear what they have to do. Click “Show editing
tools” to display the rich text editor and drag the bottom right of the text box out to expand it.
You can also provide information or resources related to the assignment,
such as a video clip, an image, or a link to a webpage.
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Display description on course page
Enabling this will display the description on the course page just below the link to the assignment activity.

Availability

Allow submissions from
The Allow submissions from setting prevents students from submitting their assignment before the shown date.
A teacher can to set a day, month, year and time (24 hour clock) from which learners can begin to submit their
assignments. Please note that this setting does not hide the activity from the learners. Instead, the learner will
see the activity, be able to view the instructions and use any materials you have included in the description, but
the learner will not be able to submit or complete the assignment until the Allow submissions from date.
This setting is enabled (ticked/checked) by default and is set at the day and time
you added the assignment. To disable this, remove the tick/check.

Due date
The Due date setting prevents students from submitting their assignment after the shown date. This
option allows an teacher to set a day, month, year and time (24 hour clock) before which learners
must submit their assignment. By default the Due date is Enabled (ticked) and is set at 7 days ahead
of the day and time you selected Add Assignment. To disable this feature, simply ensure the Enable
checkbox is not marked. For more information on using the Due Date see Assignment FAQ

••

Note: Assignments without a Due date will appear on the My home page with “No Due date” displayed.

Cut-off date
The Cut-off date is the date beyond which students will not be able to send in their assignment as the button for doing
so will no longer be displayed. After that date (or time) a teacher may, on request, grant an extension by going to the
class assignment grading screen, clicking the “Edit” column and choosing “grant extension” for the relevant student.

Always show description
This setting is used in conjunction with the Allow submissions from setting. If it is set to Yes, the
assignment Description will become visible to students at the Allow submissions from date. If it
is set to No, the assignment Description will be hidden from students until the Allow submissions
from date, only the assignment Name will be displayed as shown in the screenshot below.
However, if Allow
submissions from is
disabled, then this
setting has no meaning:
the assignment
description will always
be visible to students.
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Submission types

Select the type of submission here, and decide how you wish students to submit their work to you.

Online text
Learners can type their response directly in Moodle using the text editor.

File submissions
Learners can upload and edit one or more files of any type the teacher can open.

Submission comments
If enabled, students may leave comments into a text area associated with
the assignment. Comments can be used for communication with the
grading person, assignment progress description, to let students alert
the marker about which file is the master file (in case of inter-linked files),
or any other type of communication between student and marker.

••

Note that if Blind marking is enabled, student comments
display as from “Participant 01 etc” to avoid revealing identities.)
Submission comments will appear in the grading table (click on the
assignment activity, then click on the View/Grade all Submission button),
in the Submission comments column. Submission comments allow
two-way communication between the student and teacher.

Maximum number of uploaded files
Decide the maximum number of files which may be uploaded by each learner. It
might be helpful to display the number in the assignment description.

Maximum submission size
This setting specifies the maximum size per file of each of the files that the students can upload
as part of their submission. This maximum upload size may only be equal to or less than the
course limit (which in turn may only be equal to or less than the site limit). The maximum
size of each file is displayed to students at the point where they upload files.
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Feedback types

Feedback comments
Setting this to yes means that markers can leave feedback comments for each submission. It
enables the Feedback Comments column in the grading table.(To access the grading table, click
on the assignment activity and thenView/Grade all Submissions). Feedback comments are also
accessible by clicking on the green tick in the grade column on the grading table.
The Feedback comments column

Type feedback comments into the box

The empty Moodle gradebook

Offline grading worksheet
If set to yes, the teacher will have a link to download
the grading list as a spreadsheet. They will then be able
to enter grades and feedback comments offline:
The dropdown to download the list
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Editing the grades offline

When the teacher has completed their grading offline, they can then upload the spread sheet, confirm
the changes and the grades and comments will be transferred over into Moodle’s grade book:
Uploading the grading worksheet:

Confirming the changes:

Grades and feedback transferred into Moodl:

Feedback files
This allows markers to upload files with feedback when marking. These files may be the marked up student
assignments, documents with comments, a completed marking guide, or spoken audio feedback. It
enables the Feedback Files column in the grading table. To access the grading table click on the assignment
activity and then View/Grade all Submissions. To upload feedback files, click on the green tick in the grade
column on the grading table and then upload either with drag and drop or using the File picker.
Feedback is displayed to students on the assignment submission page.
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The Feedback files column

Upload files here

Student view with comments and file feedback both enabled

Uploading multiple feedback files
It is also possible to upload multiple feedback files as a zip, from the dropdown above the grading list:
••Download the students’ assignments using the “Download all submissions” link from the same dropdown menu.
••Extract the folder offline and add your comments to the student’s submissions. Keep the names the same.
••Select the students’ submissions and zip them into a new folder. Important: Don’t just edit them inside their original
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folder and re-zip this; it will not work. The folder name does not matter as long as the feedback files have the same
names as before.
••Upload this newly zipped folder.
••You will be presented with a confirmation screen displaying your feedback files.
Choose from the dropdown menu

Confirmation screen displaying the feedback files to be uploaded

Screen confirming uploaded feedback

Submission settings
These settings are collapsed by default

Require students click submit button
Students can upload draft versions of the assignment until such time as they are ready to submit.
Once they click the submit button they indicate to the teacher that they have finished working
on the assignment. In earlier versions of Moodle this was called “Send for marking”.)
They can then longer edit their submission. If they need to change it, they must
ask the teacher who can revert the assignment to draft status.
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To revert to the draft stage, click on the assignment activity and then View/Grade all Submissions. Locate
the student and click the action icon in the Edit column. Select Revert the submission to draft.
If this setting is No, then students do not have to to click a submit button
and are able to make changes to uploaded files at any time.
If this setting is No but the teacher wishes to grade students work, then you can stop students from making
further changes by using Prevent submission changes. Prevent submission changes can also be used in cases
where students have neglected to click the Submit button and grading has commenced. To prevent submission
changes, click on the assignment activity, then click on the View/Grade all submissions button. On the grading
table, locate the student and click the action icon in the Edit column. Select Prevent submission changes.
To do either of these with a number of students, use the ‘With selected…’ menu at the bottom of the grading table.
Reverting to draft

Prevent submission changes

“With selected”...

Require that students accept the Submission statement
An administrator can define a “Submission statement”, ie, a statement where students promise
the work is their own and which they must agree to before submitting their work. This may
be done via Settings>Site administration>Plugins>Activity modules>Assignment.
If preferred, the available default statement may be used instead: This assignment is my own
work, except where I have acknowledged the use of the works of other people.
If the administrator has given teachers the option of using a submission statement or not, then it will be available in
the assignment settings screen. The section Submission Statement explains how an administrator can set this up.
••When this setting is enabled, students will have to check a button before they can submit their assignment.
••If the administrator has forced the statement throughout the site, a teacher will not have this option in the settings
but a student will see the statement when accessing their assignment.

Attempts reopened
New feature in Moodle 2.5: This setting allows the teacher to decide how submissions are reopened.
The default is “Never”, in that students may only submit once. However, a teacher can set this to
“Manually” and reopen it themselves for the student to resubmit, or to “Automatically until pass”.
The student must then keep trying and resubmitting until they get a pass grade.

Maximum attempts
New feature in Moodle 2.5: If a student is allowed to resubmit, this setting will determine how many times they
can resubmit before they are no longer allowed to do so. (For example, if a student has to keep trying until they
get a pass grade, the teacher might decide that ten attempts is enough even though they have not yet passed!)
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Groups submission settings
(This setting is collapsed by default)

Students submit in groups
If this box is ticked, then students are able to collaborate on
an assignment. This might involve for example, working in
the same online text area, or one student uploading an MS
Powerpoint which another student downloads, improves
and re-uploads to the common assignment area.
When grading, the teacher may choose to give a common
grade and feedback to all students in the group or to give
individual grades and feedback to each member.
If no groups have been made, then Moodle will make a default group of every student in the course.

Require all group members submit
This setting will only appear if the teacher has ticked the “Require students click submit button” earlier. The
assignment will not be classed as “submitted” until all members of the group have made a contribution. When
one student has submitted, the other members of the group will be able to see who still has to submit.

Grouping for student groups
If a particular grouping is selected here, then the grade book will display any other groups and non-grouped
students in the “default group”, while naming the group(s) that are in the chosen grouping. If “none” is selected, then
the grade book will display the names of all groups and put any non-grouped students in the “default group”.

Notifications
(This setting is collapsed by default)

Notify graders about submissions
Teachers will receive a message (of a type they choose)
whenever a student submits an assignment.

Notify graders about late submission
Teachers will receive a message (of a type they choose)
whenever a student submits a late assignment.

Grade
(This setting is collapsed by default)

Grade
Specify the maximum grade or Scale to be applied to the assignment. If you
will not be giving a grade for the assignment, choose No Grade.
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Grading method
There are three options to chooswe from:
••Simple direct grading (entering a grade or scale item)
••Marking Guide (shown at the end of this section under Advanced Grading)
••Rubric (shown at the end of this section under Advanced Grading)

Grade Category
Any custom Grade Categories that have been created within your site or course will be listed here and will be available
for selection. Select the required Grade Category to add this assignment as a Grade item within this Category.

Blind marking
If this setting is enabled, then a teacher will not see the names of students who have submitted their assignments.
Instead, they will see randomly generated Participant numbers. (The student view of the assignment does not change.)
This is also the case if student comments have been enabled. Once they have graded the assignment, it is however
possible for teachers to see who submitted what by clicking on “Reveal student identities” in the Assignment settings.

Returning marks to students
Because of the nature of blind marking, the students cannot see the final grade until all of the students names have
been revealed. This is found in Assignment Settings > Reveal Student Names. However, feedback comments will appear.

••

Note: Because of this, the level of anonymity might not suit the privacy requirements of your establishment.

Common module settings
See Common module settings

Restrict access settings
The Restrict access area becomes visible in Moodle activities and resource settings
if Conditional Activities have been enabled by the administrator.

Locally assigned roles
In Settings > Assignment administration > Locally assigned roles, you
can select users to give additional roles in the activity.

Advanced Grading
Marking guide
A marking guide is an advanced grading method where a teacher enters
a comment and a mark, up to a maximum, per criterion.

Selecting Marking guide
Create an assignment, and in the Grades
section, choose from the Grading method
drop down menu the Marking guide option:
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Creating a new Marking guide
•• When the assignment has been created
and Marking guide selected as above, click
Save and display and choose Define new
grading form from scratch.
•• Give the guide a name and description.
•• Click on the criterion name to edit it. It
will open up a box for typing into.
••Click the Click to edit links to provide an explanation for students and for markers as to what is required. It will open
up a box for typing into.
•• Click the Click to edit link to allocate a
maximum mark for this criterion. It will open up
a box for typing into.

Adding more criteria
Click the button to add one or more criteria
(and then repeat the process as above)

Adding frequently used comments
If a teacher regularly uses the same comments
when marking, it is possible to add these
to a frequently used comments bank.
•• Click the Click to edit link and add a comment.
•• Click the +Add frequently used comment
button to add another one and repeat as needed:

Marking guide options
By checking the appropriate boxes it is possible to allow students to see (or not)
the guide definition and how many marks are allocated per criterion.

Saving and using Marking guide
Once completed, the guide may be saved as a draft or saved and made ready to
use, according to the button selected at the bottom of the screen.
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Editing or deleting Marking guide
Once completed, a guide may be edited or
deleted by going to Settings>Assignment
administration>Advanced grading>Marking
guide. Options appear to edit or delete
the currently defined form.

When an assignment has been graded, a warning appears if the guide is edited
to check whether the assignments need to be regraded or not.

Using templates
Those users with the capability Capabilities/moodle/grade:sharegradingforms
(and perhaps Capabilities/moodle/grade:managesharedforms) may save
their forms as a template for others to use. They will see an additional
option in Settings>Assignment administration>Advanced grading

••

Note that teachers do not have these capabilities by default

If templates have been
made available, then
on first accessing the
Marking guide, teachers
may select to “Create a
new grading form from a
template”. This will open
up a search box to locate
the desired template:

Marking assignments
When the assignment to be graded is accessed in the usual way, the form appears with the
criteria and an empty comments and score box. If frequently used comments have been added,
the teacher clicks into the box and then clicks on the required comment to insert it:
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How students view the marking guide
When students click on an assignment which has a marking guide attached to it, they will see the marking guide
as part of the information about their assignment. Thus, they can see the marking guide before they submit.

Student view of marking
guide on assignment
grading screen

Rubrics
Rubrics are advanced grading forms used for criteria-based assessment. The rubric consists of a set
of criteria. For each criterion, several descriptive levels are provided. A numerical grade is assigned to
each of these levels. The person rating chooses which level answers or describes the given criterion
best. The raw rubric score is calculated as a sum of all criteria grades. The final grade is calculated
by comparing the actual score with the worst/best possible score that could be received.

Rubric editor
The rubric editor is available via the advanced grading method management screen which
in turn is available via the ‘Advanced grading’ link in the activity settings block.
The editor lets you set the rubric form name, the description and the rubric itself. The editor lets you
add new criteria and levels, delete them and change the criteria order. There are several rubric options
that can be configured, too. For each criterion, the criterion description should be filled. For each level,
the level definition and the number of points associated with the level should be specified. Neither
the criterion description nor the level definition text fields support embedded images yet.
The rubric definition must be saved using either ‘Save rubric and make it ready’ or ‘Save as draft’ button.
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••
••

Tip: You can modify the effective weight of a criterion by setting the value of the points assigned
to its levels. If there is one criterion with levels 0, 1, 2, 3 and the second one with levels 0, 2,
4, 6 then the later one’s impact on the final grade is twice as much as the first one’s.
Tip:Use the Tab key to jump to the next level/criteria and even to add new criteria.

Using the rubric
When teachers use
the rubric to assess
some student’s
work, they select
the level describing
the student’s
performance
best for each
criterion. Currently
selected levels
are highlighted
in light green.
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If the rubric filling is re-edited later, the previously selected level is highlighted in light red. A level must be selected
for each criterion, otherwise the rubric is not validated by the server as the final grade can’t be calculated.
If the form definition allows it, an optional remark can be filled for each criterion
providing a detailed feedback/explanation of the assessment.

••

How students access the rubric

When students click on an assignment which has a rubric attached to it, they will see the rubric as part
of the information about their assignment. Thus, they can see the rubric before they submit.

Editing a rubric
To edit a rubric go to Administration > Assignment Administration > Advanced grading > Define Rubric.
Select ‘Rubric’ from Change active grading method to drop down menu.
You can see your created rubric with three options above:
••Edit the current form definition
••Delete the currently defined form
••Publish the form as a new template.
Click “Edit the current form definition” to edit your predefined rubric form.

Choosing another rubric
From Administration>Assignment administration>Advanced grading access your rubric and delete it.
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Chat activity
ADDING A CHAT TO YOUR COURSE
With the editing turned on, in the section you wish to add your chat, click the “Add an
activity or resource” link (or, if not present, the “Add an activity” drop down menu ) and
choose Chat. All settings may expanded by clicking the “Expand all” link top right.

General
Name of this chat room
Whatever you type here will form
the link learners click on to enter
the chat so it is helpful to give it a
name that suggests its purpose - for
example “Student council discussion”
or “Field trip planning meeting”.

Description
Type the description of the chat here. Include precise instructions for students regarding the subject of the chat.
Click “Show editing tools” to display the rich text editor, and drag the bottom right of the text box out to expand it.

Display description on course page
If this box is ticked, the description will appear on the course page just below the name of the Chat.

Chat sessions
Next chat time
This sets the day and hour of
the next chat session. These
details will appear in the
calendar so students know
the schedule but it doesn’t
stop them accessing the
chatroom at any other time.
If you don’t want them
in the chatroom at other times, then hide it (with the eye icon) or use Conditional activities to restrict access.
If you don’t wish to schedule chat times then ignore this and choose from the next settings.

••

Tip: For courses involving users across different time zones, it is useful to know that the time you set here will
be adjusted to match the time zone of the user viewing it.
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Repeat/publish sessions
There are four options for scheduling future chat sessions:
••Don’t publish any chat times - there are no set times and students are welcome to chat at any time.
••No repeats - publish the specified time only- only the Next chat time will be published. This could be used to schedule
special events or meetings or simply to help learners identify a common time in which they can expect to find other
learners in the chat room.
••At the same time every day- Daily chats are useful for scheduling daily office hours or work sessions with learners.
••At the same time every week--This setting will schedule a chat for the same day and time every week, which could be
useful for instance for meeting and reviewing key ideas and questions related to the week’s content/assessment.

Save past chat sessions
Choose from the dropdown how many days to save - or save everything by selecting Never delete messages.
If you have any concerns about discussions that might take place in your chat room, you may want to
keep transcripts to check the suitablility of what is discussed. If your learners are using the chatroom to
collaborate on a group project you won’t want to delete the messages until the project is complete.

Everyone can view past sessions
Decide here whether or not allow everyone to view past chat sessions. (Teachers can always view past sessions)

Common module settings
These settings are collapsed by default. See the separate section on Common module settings

Restrict access/Activity completion
These settings are collapsed by default. These settings are visible if Conditional activities and Activity completion have
been enabled in the site and the course. See the separate section on Conditional activities and Restricting access.

Locally assigned roles
In Administration > Chat administration > Locally assigned roles selected users can be given
additional roles in the activity, such as the capability to delete chat logs. Role permissions for
the activity can be changed in Administration > Chat administration > Permissions.

USING CHAT

Entering the chat
As you click the chat link on the
course page you see options:
••Click here to enter the chat now - this takes you to
the chat using the chosen site default chat method
- for example Ajax.
••Use more accessible interface - this gives a
simpler chat room without frames and javascript:
••View past sessions - when enabled and the user is
allowed to view past chat sessions, this takes them
to a list of past sessions with links to the chat.
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Joining in a chat session
•In
• normal view, the screen is in two
parts with the participants on the right,
the messages on the left and a box at
the bottom into which users type their
message and press “Send” to make their
contribution: users can change the
appearance of messages by clicking on
‘Themes’ next to the ‘Send’ button.

••

Bubbles appears thus:

The chat module contains some features to make chatting a little nicer.
••Smilies: any smiley faces (emoticons) that you can type elsewhere in Moodle can also be typed in here and they will
be displayed correctly.
••Links: iInternet addresses will be turned into links automatically.
••Emoting: you can start a line with /me to emote. For example, if your name is Kim and you type /me laughs! Then
everyone will see “Kim laughs!”
••Beeps: you can send a sound to other people by hitting the “beep” link next to their name. A useful shortcut to beep
all the people in the chat at once is to type “beep all”.
••HTML: if you know some HTML code, you can use it in your text to do things like insert images, play sounds or create
different coloured and sized text.

Chat reports
To view previous chats (if you have permission) click on the
‘View past chat sessions’ link. Teachers can also access past chat
sessions from the Chat administration in the Settings block.
••
This will bring up a listing of each chat session under the current chat
topic. The listings include the time the chat started and ended, which users
participated, and how many messages each user sent.
••
In order for students to see past sessions, the teacher or an administrator
must setup the chat to allow everyone to view past chat sessions.

Exporting chat sessions
Managers, teachers and non-editing teachers can download
or export past chat sessions to any portfolio enabled by
the administrator. If Portfolios have not been enabled, then
users will not see a link to “Export” chat sessions.
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Reasons to use chat
Chat has an advantage over a Forum in that it takes place in Real Time. It is especially beneficial
when the group chatting is not able to meet face to face. Examples might be:
••Regular meetings of staff on large or split campuses to discuss student or curriculum issues;
••Regular meetings of students doing online courses to enable them to share experiences with others on the same
course but potentially in a different city (or country)
••A teacher working with his students even though he is out of school
••A student temporarily unable to attend in person chatting with their tutor to catch up with work.
••Students out on work experience getting together to discuss their experiences with each other and their tutor
••Younger children using chat at home in the evenings as a controlled(monitored) introduction to the world of social
networking

Reasons NOT to use chat
Unless a tutor/moderator is permanently present in the chatroom -or unless the chat is hidden
and revealed at certain times, it is difficult to control what is said once a chat has started.
Younger students particularly may find it difficult to stay on task and be prone to
adding non-useful comments or “beeping” others for the sake of it.
In some situations, a forum might be preferred as it allows for reflection before
posting and gives a period of time where the post might be edited.
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Choice activity
A choice activity is very simple –
the teacher asks a question and
specifies a choice of multiple
responses. It can be useful as a
quick poll to stimulate thinking
about a topic; to allow the class to
vote on a direction for the course;
or to gather research consent.
Choice requires some preparation
time for creating your activity
and thinking about what results
you would like to achieve, but
your participation with activity
itself is likely to be minimal.

CHOICE ADMINISTRATION SETTINGS
With the editing turned on, choose from the “Add an activity or resource” link (or, if not present, the “Add an
activity” drop down menu) the option Choice. To see all the settings expanded, click “Expand all” top right.

General
Choice name
A short name of the choice
(e.g. “Favourite colour”).
This will be displayed on
the course’s homepage.

Description
Type the description of the
choice activity here. Click “Show
editing tools” to display the
rich text editor and drag the
bottom right of the text box out
to expand it. It should contain
the question that you want your students to answer. An example of the choice text could be “What is your favourite
colour?” There is also an option to display the choice description on the course page below the link to the activity.

80

Key:

Teacher view

Student view

Admin setting

Tip

Display mode for the options
Choose “horizontally” if you only have three or four choices maximum;
choose “vertically if you have a large number of choices.

Options
Allow choice to be updated
If this is set to “Yes”, students can change their
mind after they have voted. If it’s set to “No”,
students cannot change their choice.

Limit the number of responses
Enabling this option allows you to limit the number of
participants who can select each particular choice. When that
number has been reached, no one else can select that choice.

••

Warning!! If you unintentionally check this box
but don’t add a number then your students won’t be
able to select any choices and will get confused :)
Option

Specify here the options that participants have to choose from.
They will become radio buttons when the choice is saved.
You can leave other options blank or click “Add
3 fields to form” to add more options.
If Limits is disabled, then any number of participants can select any of the options.

Availability
(These settings are collapsed by default)

Restrict answering
If you check this box you can set an “open and close” date for your choice. If you leave it, they can respond at any time.
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Results

Publish results
This determines whether (and when) the students will be able to view the results of the choice activity. They may:
••never see the results of the choice
••see the results only after they have given the answer themselves
••see the results only after the closing date of the choice
••always see the results

Privacy of results
If “Publish” was chosen above, then this dropdown in unlocked. You can decide whether to
show names of students or merely the number who responded but without names.

Show column for unanswered
If set to “Yes”, this will display a column showing how many participants have not answered the choice
activity yet. If this is set to “No”, the results will only include the participants who have already voted.

Common module settings
These settings are collapsed by default. See Common module settings for more information.

Restrict access and Activity completion
These settings are collapsed by default. These settings are visible if Conditional activities and Activity
completion have been enabled in the site and the course. See the separate section for more information.
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••

What the student sees

When a teacher has created a Choice activity, the student is presented with a
number of radio buttons. They click one to make their selection.

Depending on the teacher’s settings, the student may then be able to see the results either
anonymously or with names (via the “View xxx responses” link) or not see anything.

••

What the teacher sees

Regardless of how it’s been set
for students, a teacher will always
see user names and choices, via
the “View xxx responses” link.
The teacher is also able to delete selected
choices or download them in various
formats as in the screenshot above.

Some ways to use Choice
Thinking about existing knowledge
Pedagogically, the choice activity can be used to provide an opportunity to share starting points
through which learners are encouraged to think about and articulate existing knowledge and
understandings of a topic. For example, you can ask students to make ‘choices’ about a statement
such as “in learning to become a teacher, the most significant issue for me is” (giving the following
choices): trust, theoretical underpinnings, communication or delivering materials to students.
This has two benefits: firstly, it forces participants to engage with their choice and think, in advance of
a further related activity (you might wish to follow up such a choice activity with a forum discussion
or a reflective activity like the online text assignment), about the context and consequences of this
choice. Secondly, it allows tutors and students to gain a better understanding of existing views/
understandings/knowledge related to the question, idea or concept at hand in the Choice activity.
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Assessing understanding
For younger students, the choice activity is a secure way to gauge their understanding of a topic
without asking them in public: with a question such as “how well did you understand this module?”
students can honestly select from “very well”, “OK” or “I still don’t get it”, safe in the knowledge only
their teacher knows their response and they will not be shamed in front of their peers.
The choice activity in Moodle only allows a participant to select one choice from a variety of options
(that you provide), but you may set the activity so that participants can change their choices - thus, as
students make progress and gain confidence, they might want to update their choice to reflect this. You
can also set the activity so that it ‘closes’ or ‘locks down’ on a specific date, making all choices final from
that point on. This allows participants to change their minds several times before a final date.

Selecting groups
Using the choice activity is one way of getting students to put themselves into groups.
However in its standard form, it does not add them to the grade book as a group.
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Forum activity
ADD AND EDIT A FORUM
••With the editing turned on, in the section you wish to add your forum, click the “Add an activity or resource” link (or, if
not present, the “Add an activity” drop down menu )and choose Forum.
••This will take you to the forum settings page titled “Adding a new forum”.
You can access an existing forum by clicking the configure icon or clicking on the
forum and then Administration > Forum administration > Edit settings.

General
Forum name
A short name of the forum
which will be displayed on
the course homepage.

Description
Give clear instructions
so users know what to
do. Click “Show editing
tools” to display the rich
text editor and drag the
bottom right of the text
box out to expand it.

Display description on course page
Enabling this will display the description on the course page just below the link to the forum.

Forum type
There are five forum types to choose from:
••A single simple discussion - A single topic discussion developed on one page, which is useful for short focused
discussions (cannot be used with separate groups)
••Standard forum for general use - An open forum where anyone can start a new topic at any time; this is the best
general-purpose forum
••Each person posts one discussion - Each person can post exactly one new discussion topic (everyone can reply to
them though); this is useful when you want each student to start a discussion about, say, their reflections on the
week’s topic, and everyone else responds to these
••Q and A Forum - Instead of initiating discussions participants pose a question in the initial post of a discussion.
Students may reply with an answer, but they will not see the replies of other Students to the question in that
discussion until they have themselves replied to the same discussion.
••Standard forum displayed in a blog-like format
••News forum is a special type of forum that is automatically created with a new course.
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Attachments and word count
(This setting is collapsed by default)

Maximum attachment size
The maximum file size that may be attached to a
forum post will first be determined by the Moodle site
settings. The teacher may want a smaller size limit for
the forum. Server file capacity, student downloading
speeds and discouraging images in a document
centred discussion are a few reasons to limit file size.

Maximum number of attachments
The maximum number of attachments a user can add to
their forum post (from 0 to 100) can be specified here.

Display word count
New feature in Moodle 2.5 If “Display word count” is enabled, then the number of
words in forum posts will be shown at the bottom of each post.

Subscription and tracking
Subscription mode
When a user is subscribed to a forum it means that
they will receive notification (via popup and/or
email, depending on the user’s messaging settings
preferences) of each new posting. By default, posts
are recorded about 30 minutes after the post was first
written. Depending upon the email settings of each
forum member, they may be sent an email immediately
after the 30 minute edit window is closed, or in a batch at a time fixed by the site administrator (see below).
People can usually choose whether or not they want to be subscribed to each forum.
However, the teacher can choose to force subscription on a particular forum then all course
users will be subscribed automatically, even those that enrol at a later time.

There are 4 subscription mode options:
••Optional subscription - Participants can choose whether to be subscribed
••Forced subscription - Everyone is subscribed and cannot unsubscribe
••Auto subscription - Everyone is subscribed initially but can choose to unsubscribe at any time
••Subscription disabled - Subscriptions are not allowed.
The subscription mode and subscribe or unsubscribe links appear in Navigation>Forum administration
when viewing the forum. Teachers can quickly change the mode via the ‘Subscription mode’
options and view the current subscribers via the ‘Show/edit current subscribers’ link.

••

Tips:

••Forcing everyone to subscribe is especially useful in the news forum and in forums towards the beginning of the
course (before everyone has worked out that they can subscribe to these emails themselves).
••Changing the setting from “Yes, initially” to “No” will not unsubscribe existing users; it will only affect those who enrol
in the course in the future. Similarly changing “Yes, initially” will not subscribe existing course users but only those
enrolling later.
••“Subscriptions not allowed” setting prevents Students from subscribing. Teachers may subscribe if they wish to.
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Read tracking for this forum?
“Read tracking” for a forum allows users to track read and unread forum posts.
There are three options for this setting:
•• Optional (default) - Students can turn tracking on or off for the forum
via a link ‘Track / Don’t track unread posts’ in Administration > Forum
administration
•• On - Tracking is always on in this forum (so no link in Administration >
Forum administration)
•• Off - It is not possible to track unread forum posts

••

Note: The first two options require users to also have
forum tracking set to yes in their profile settings. Currently the forum
tracking profile setting overrides the read tracking forum setting.

RSS

••

This setting is collapsed by default and will only
appear if RSS has been enabled site wide and for forums.
RSS feed for this activity

This turns RSS on or off for this forum. When set to “None,”
RSS is disabled. When set to “Discussions,” the RSS feed will
send out new discussions to subscribers. When set to “Posts,”
the RSS feed will send out any new posts to subscribers.

Number of RSS recent articles
This number sets the number of articles that go out via RSS. If this number is set to 5, then the 5 most recent
articles will be sent to subscribers. As new posts (or discussions) get added, the oldest post/discussion gets
replaced on the RSS feed. If your forum gets a lot of posts every day, you will want to set this number high.

Post threshold for blocking
Time period for blocking
Choose here the time period in which a
user can be blocked from posting more
than a given number of posts.

Post threshold for blocking
Set the number of posts here that users
may add before they are blocked.

Post threshold for warning
Set the number of posts here after which users will be warned they are about to be blocked.

Grade
This setting is collapsed by default. Choose the category in which this forum will appear if ratings are enabled.
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Ratings

Roles with permissions to rate
Forum posts can be rated using a scale. By default, only teachers can rate forum posts, though students
can be given permission to do so if desired (see Forum permissions below). This is a useful tool for giving
students participation grades. Any ratings given in the forum are recorded in the grade book.

Aggregate type
You can set an aggregate type, in other words, decide how all the ratings given to posts in a forum
are combined to form the final grade (for each post and for the whole forum activity). Some
scales do not lend themselves to certain types of aggregates. There are five options:
••Average of ratings (default) - This is the mean of all the ratings given to posts in that forum. It is especially useful with
peer grading when there are a lot of ratings being made.
••Count of ratings - The counts the number of rated posts which becomes the final grade. This is useful when the
number of posts is important. Note that the total can not exceed the maximum grade allowed for the forum. A count
may be used if the teacher simply wants to acknowledge that a reply was given in the case students being required to
make a certain number of posts in the discussion. Note: Count of ratings does not work for the “Separate or Connected
Ways of Knowing” scale or custom scales due to the limitation imposed by the max grade.
••Maximum rating - The highest rating is returned as the final grade. This method is useful for emphasising the best
work from participants, allowing them to post one high-quality post as well as a number of more casual responses to
others.
••Minimum rating - The smallest rating is returned as the final grade. This method promotes a culture of high quality for
all posts.
••Sum of ratings - All the ratings for a particular user are added together. Note that the total is not allowed to exceed the
maximum grade for the forum. Note: Sum of ratings does not work for the “Separate or Connected Ways of Knowing”
scale or custom scales due to the limitation imposed by the max grade.

Restrict ratings to items with dates in this range
The teacher can allow only posts within a certain date range to be rated. This is useful if the teacher wants to
keep students focused on the most recent content and maintain a specific pace within the forum or course.
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Common module settings

••

See the section ‘Common module settings’
for more information, but note the details below
relating specifically to use of forums with groups.

Group mode
The group mode setting has three options:
••No groups
••Separate groups - each group can only see their own group; others are invisible
••Visible groups - each group works in their own group, but can also see other groups

If the group mode is set to separate groups:
Teachers are given the option of adding a new
discussion topic for all participants or for a selected
group. If a teacher adds a new discussion topic for
a selected group, then only group members can
reply to it. If a teacher adds a new discussion topic
for all participants, then students can’t reply to it.
(This is to ensure that groups are kept separate.)
••Students can only start discussions for their own group.
••Students can only reply to discussions started by other group members or discussions for their own group started by a
teacher.

If the group mode is set to visible groups:
••Teachers are given the option of adding a new discussion topic for all participants or for a selected group. If a teacher
adds a new discussion topic for a selected group, then only group members can reply to it.
••Students can only start discussions for their own group.
••Students can only reply to discussions started by other group members or teachers.
Teachers, and other users with the capability moodle/site:accessallgroups set to allow, can
view and post in all forum discussions, regardless of the group mode setting.

••

Note: Single simple discussions cannot be set to separate groups (as this feature is not
implemented). Instead, a standard forum should be used, with the teacher copying and
pasting the same discussion topic for each separate group. If required, a permissions
override may be set to prevent students from starting new discussions.

Restrict access/Activity completion
These settings are visible if Conditional activities and Activity completion have been enabled in the
site and the course. See the separate section on ‘Conditional activities and Restricting access’.
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Locally assigned roles

••

In Administration > Forum administration > Locally assigned
roles selected users can be given additional roles in the activity.
Forum moderator
A forum moderator for a particular forum is able to edit or delete forum
posts, split discussions and move discussions to other forums. This role
could be useful for example if you wish a student to be able to moderate
a student forum but not have editing rights over the whole course.
To assign a student the rights to moderate a forum, assign them the role of non-editing teacher in the forum.
••In Settings > Forum administration > Locally assigned roles click on student
••Select the student from the potential users list on the right, and use the Add button to add them to the existing users
list on the left. Multiple users may be selected by holding down the Apple or Ctrl key whilst clicking on the users’
names.

Forum permissions

••

Role permissions for the activity can be changed in Administration > Forum administration > Permissions.
Enable students
to rate posts
Click the Allow icon (+) opposite
the capability to rate posts
and allow the role of student.

Archive a forum
Click the Prevent icon (X)
for the student role for the capabilities ‘Start new discussions’ and ‘Reply to posts’. Then a forum becomes closed
(archived). Students may no longer start new discussions, nor add replies, but can still read all the discussions.

Guests and posting in a forum

••

There are certain things that guests are never allowed to do, such as posting in
a forum, despite the permissions interface suggesting otherwise.

The guest role has some special functionality, for example when a guest user attempts to post in a forum, they
obtain the message “Sorry, guests are not allowed to post. Would you like to log in now with a full user account?”

••

Note: If guests don’t obtain the “Sorry, guests are not allowed to post” message because they have no reply
link, then self enrolment needs enabling in Settings > Course administration > Users > Enrolment methods.

If you wish guests to be able to post in a forum, you can create a similar role, say “visitor” with very few permissions
allowed, then create an account and assign it the role of visitor. Guests can then share this visitor account.
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User administration settings
Users can choose whether or not to track unread posts in their profile settings under ‘Forum tracking’. The settings are:
••Yes: highlight new posts for me
••No: don’t keep track of posts I have seen
If the user chooses ‘Yes: highlight new posts for me’ and the forum administrator has set
the ‘Read tracking for this forum?’ to ‘On’ or ‘Optional’ then the user will have new posts
highlighted for them. The posts will be highlighted in the following places:
••My home page
••Course page
••Within the forum itself
••In forum discussion threads
Showing unread on forum page

FORUM VIEWS

A single simple discussion
Students will see the text you have placed in the Forum introduction setting as the first post of the discussion. Below
you will find the replies that have been posted. In the example below, the student sees that their reply was rated.
Student view of ‘Single simple discussion’ forum
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Each person posts one discussion
The view will be basically the same as in the previous case, the only difference being the ‘Add a new
discussion’ option. Viewing a forum page, the student will see the text you have written at the ‘Forum
introduction’ space while creating the forum, and, if there are any, the discussions that have been started.
Student view of ‘Each person posts one discussion’ forum

Standard forum for general use
In this forum type, students will see the introduction text in a separate space above the discussion
field, in which you will see the information such as the title of the discussion (which means
the forum’s title), its author, the number of replies and the date of the last post.
Student view of ‘Standard’ forum

Question and Answer forum
The Q & A forum is best used when you have a particular question that you wish to have answered.
In such a forum, teachers post the question and students respond with possible answers. By default
a Q and A forum requires students to post once before viewing other students’ postings.

Students’
initial view of
a Q&A forum
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Students cannot see posts until they post

Other posts visible when editing time is over

In Administration> Forum administration,
students may see the options the teacher
has set for subscriptions to the forum.
This is also where the teacher will
find the forum “Edit settings” link and
other links to forum controls.
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Display options
A discussion thread may be displayed in four ways. Use the pull down
menu at the top of each forum discussion to select a display type

••Display replies flat, with oldest first
••Display replies flat, with newest first - The discussion will be displayed in one line and the chronological order from the
newest to the oldest. This is the same as the above, just a different sort order.
••Display replies in threaded form - Only the post starting the discussion will be displayed in its full form; replies will be
reduced to the headlines (including information about its author and date of release) and organized chronologically;
moreover, replies will be shifted towards the right so that only replies to the same post were in the same line.
••Display replies in nested form - All posts are displayed in their full forms; replies will be reduced to the headlines
(including information about its author and date of release) and organized chronologically; moreover, replies will be
shifted towards the right so that only replies to the same post were in the same line.

Forum posting
The default content of Subject is usually ‘Re: <the name of the ‘parent’ post>’. You can change it though.
When writing text in Moodle there are several formats you can choose to produce your text, depending on your
expertise and the type of browser you are using. Please refer to Formatting text for further information.

Sharing images through forums
When an image is “attached” as a file to a forum message, it is immediately displayed full size after the
message (i.e. no need to click on an attachment). This an excellent way of sharing images without having
to go through the process of uploading them as files and linking them from within web pages.

Images may be dragged and dropped into the box as well as uploading via the “add” link and the File picker.
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Sharing sound and video through forums
If multimedia filters are enabled, a sound file (mp3) or accepted video file can be attached
and it will be embedded into the forum post in an appropriate player.
As with images in the previous section, multimedia files may be dragged and
dropped from the desktop instead of uploaded via the File picker.

Post length
Extra-long posts cause problems when doing a forum search and can be difficult to read on screen. Rather than creating
a very long post, consider copying and pasting the text into a text file and add it as an attachment to your forum post.

Post editing time limit

••

There is a time limit for editing posts, usually 30 minutes. It is set by an
administrator in Administration > Security > Site policies.

Mail now
A mail now checkbox is available for anyone with the capability to manage
course activities, normally teachers and administrators.
Checking the “Mail now” box results in a notification being sent immediately to everyone
subscribed to the forum, rather than after the post editing time limit.
Note: For users who have enabled email digests in their profile, the notification
is NOT sent separately from other forum post notifications.

Exporting forum posts
Users with the mod/forum:exportdiscussion or mod/
forum:exportownpost or mod/forum:exportpost permission can
export forum posts to any portfolio the administrator has enabled:

Moving a discussion
Teachers, non-editing teachers (and managers) may
move a discussion to any other forum in the course
for which they have appropriate rights.
•• Click on the arrow in the ‘Move this discussion to...’ dropdown menu
in the top right corner of the page and select a destination forum.

••

•• Click the Move button.

Note: Moving a forum post will display incorrect results in the course participation report for
the affected forums. For example, take a student who posted in forum A and had their post
moved to forum B. In the course participation report the student will still be listed has having
made a post in forum A, but will not be listed as having made a post yet in forum B.
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GUIDELINES FOR TEACHING AND LEARNING FORUMS
Moodle has four kinds of forums each with a slightly different layout and purpose.
Which of the forums will best suit your needs for a particular activity? In order to answer this question, it
is useful to think how you might lead such a discussion in a face-to-face environment. Would you throw
the question out to the class and sit back to observe them in their answers? Or would you break them up
into smaller groups first and ask them to have discussions with a partner before bringing them back to
the main group? Or perhaps you would like to keep them focused on a particular aspect of a question and
ensure that they do not wander away from the topic at hand? All of the above approaches are both valid
and useful, depending on your learning outcomes, and you can replicate all of them in Moodle forums.

A standard forum for general use
The standard forum is the most useful for large discussions that you intend to monitor/guide or for social forums
that are student led. This does not mean that you need to make a new posting for each reply in each topic,
although, in order to ensure that the discussion does not get ‘out of control’, you may need to be prepared to spend
a significant amount of time finding the common threads amongst the various discussions and weaving them
together. Providing overall remarks for particular topics can also be a key aspect of your responsibilities in the
discussion. Alternatively, you could ask students to summarize discussion topics at agreed points, once a week or
when a thread comes to an agreed conclusion. Such a learner-centred approach may be particularly useful once
the online community has been established and, perhaps, when you have modelled the summarizing process.

Standard forum displayed in blog-like format
This forum behaves in the same way as the default standard forum for general use, allowing users to start their own
discussions. However, it displays differently in that the first post of each discussion is displayed (as in a blog) so that
users can read it and then choose to respond by clicking the “Discuss this topic” button bottom right of the post.

A single simple discussion
The simple forum is most useful for short/time-limited discussion on a single subject or topic. This kind
of forum is very productive if you are interested in keeping students focused on a particular issue.

Each person posts one discussion
This forum is most useful when you want to achieve a happy medium between a large discussion
and a short and focused discussion. A single discussion topic per person allows students a little more
freedom than a single discussion forum, but not as much as a standard forum where each student can
create as many topics as he or she wishes. Successful forums of this selection can be active, yet focused,
as students are not limited in the number of times they can respond to others within threads.

Question and Answer forum
The Q & A forum is best used when you have a particular question that you wish to have answered. In a Q and A
forum, tutors post the question and students respond with possible answers. By default a Q and A forum requires
students to post once before viewing other students’ postings. After the initial posting and once the editing
time (usually 30 minutes) has elapsed, students can view and respond to others’ postings. This feature allows
equal initial posting opportunity among all students, thus encouraging original and independent thinking.

••

Note: Students do not see the “add a new question” button in the Q & A forum. If you wish students
to be able to add new questions, they need to be given the capability mod/forum:addquestion

In Question and Answer mode, Moodle hides the replies to the initial thread post by the teacher but not the forum itself.

••

Tip: Post each question as a thread in the forum and then have students post replies to the
question. In this fashion, Moodle will protect the replies from being viewable (subject to the caveat
above) by other students but allow the initial post/thread visible for reply by all students.
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••
••

Tip: Do not post the question in the forum summary because every student answer will become a thread
and visible to all students. In this scenario, it may appear as if the Question and Answer forum is not working
correctly, since the new initial posts in the thread are intentionally designed not to be hidden, just their replies.
Tip: If you have set up groups for your forum the facilitator needs to post a question to each
of the groups and not to ‘all participants’ as questions asked of all participants (students) are
able to be read by ALL students. Questions posed to group members are only visible to those
group members and replies are only visible once a group member has posted a message.

Forum subscription
When a person is subscribed to a forum, they will be notified (according to their Messaging settings
preferences) of every subsequent post in that forum. Posters have 30 minutes by default to edit
their post before it is sent though this time limit can be changed by an administrator.
People can usually choose whether or not they want to be subscribed to each forum. However, if a
teacher forces subscription on a particular forum then this choice is taken away and everyone in the
class will get notified. This is especially useful in the News forum and in forums towards the beginning of
the course (before everyone has worked out that they can subscribe to these emails themselves).

••

Note that even if you force subscriptions every user can elect not to be notified in Messaging settings, or
elect to have all email sent once a day in a digest contain either all posts or simply the subject headings.

Choosing Everyone can choose to be subscribed enables you to check (and modify) the number of
subscribers (Settings > Forum administration > Show/edit current subscribers) and to subscribe to,
or unsubscribe from, the forum (Subscribe to this forum / Unsubscribe from this forum).

Concepts for use in forums
Participation and Scaffolding
Whilst one of the great advantages of e-learning is the flexibility it affords participants, this does not mean
that days or weeks should pass without response and discussion in a forum (unless it is appropriate for it to
do so). This is perhaps most especially true at the beginning of a course or programme when students and
tutors are new to each other and in need of welcome messages/encouragement. Whilst e-learning, and
discussions in particular, can support learning that is not always tutor/teacher-centred, your role will be
important, especially as an online community begins to develop. It is during these initial stages of introductory
material that a group of students can become a community of participants who begin to grow in their
understandings of course material and individual contributions to the knowledge construction process.
As the discussions progress and learners become accustomed to the mechanics and the tone of the forums
then there are key ways in which your input can be reduced, thereby helping to foster a community that is
less dependent on the tutor/teacher. Even then, however, you will probably want to be a presence in the
discussions although you may choose to be one of many contributors rather than the font of all wisdom.

Commitment and Participation
Ask yourself if
••you wish to have involvement in the forum or if you want the students to lead and own the space
••you want the forum to add value to the face to face environment or have a life of its own in its own right outside the
lecture theatre/classroom or seminar room
••you are prepared to make appropriate contributions to the discussion in order to:
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••encourage discussion if students are quiet
••help shape ideas if students begin to wander off-task
••your role will be defined as discussions/a course progresses
••you will explicitly but gradually relinquish control of the discussions
••you will encourage and support learners to share control of discussions(for example you might ask a learner/group
of learners to summarise contributions to a discussion thread/topic or you might ask learners to initiate discussion
topics)

Student Centred Forums
With the growing popularity of social networking software like Facebook, Bebo, MySpace and the like, students
are leaving schools and coming to Higher and Further Education with a new technological sophistication and with
new expectations for communication. And as school, colleges and universities recognise that reflective and lifelong learning are significant goals in education, student centered learning and the creation of student centred
spaces online are also gaining credence in educational settings. We know that effective learning requires access
to social and academic networks for both study material and emotional support; as such, online communities can
offer a holistic knowledge construction and support mechanism and recognize that affective activity is effective.
Social forums, often called ‘Virtual Cafes’ or ‘Common Rooms’ can be set up for courses or for programmes, depending
on the student need. Such spaces provide a common area for students to come together and discuss unlimited
topics, including social activities and educational ideas. They are supportive spaces for students, most successful with
large first and second year courses where students would not otherwise have the opportunity to communicate with
others outside their own tutorial group. It is arguable that students will experience a greater sense of community
within and a sense of belonging to an educational institution or individual department having had the experience
and convenience of the social forum on their course; this could arguably have implications for retention.
These spaces are typically highly active, especially in first term. Depending on your institution,
they are usually self-monitored by students, who understand that the same ‘rules’ and
‘netiquette’ that apply to them within any computing space, also apply in Moodle.

The News Forum
Moodle courses automatically generate a News forum which defaults to automatically subscribe all
participants in a course. The name of the News Forum can be changed to something more appropriate,
such as ‘Important Announcements’ or the like. This is a useful feature and many use this forum in a Moodle
course to announce exam dates, times or changes to exams, lectures or seminars, as well as important
information about course work throughout a term or special announcements relating to events.

Teacher/Tutor forums
A teacher/tutor-only forum may be added to a course by creating a hidden forum.
Teachers are able to view hidden course activities whereas students cannot.

Some forum suggestions to consider
If your course is at a distance, if your face to face time is limited, or if you just wish to foster a sense of
community in your Moodle course which supplements your face to face course, it is good practice to begin
with a welcome or introductory message or thread in one of your forums. This welcome or introduction
from you invites participants, for example, to post some specific details to introduce themselves to
you and their peers. This can be your icebreaker or you can have an icebreaker separately.
If you have two questions for participants to answer, starting the two strands or topics within the forum itself will
both help learners to see where to put their responses, and remind them to answer all parts of your question.
Remember that you are communicating in an environment that does not have the benefit of verbal tone, eye
contact, body language and the like. Careful consideration of your communication is, therefore, necessary.
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Postings to a forum are always written but they can take different forms and you may wish to consider what form
best suits the activity. For instance, you might choose to articulate a form of contribution in order to be explicit.
Thus you might say, ‘This is a think-aloud forum in which, together, we will try to tease out ideas and possibilities’
or ‘This is a formal forum in which you are invited to share your ideas on (topic)’ and, where you select the latter,
you might have already suggested learners plan those ideas offline or in another kind of activity within Moodle.
Create a forum where only the teacher can start discussions, but the students can only reply. Each thread
you start contains an essay question (or several similar ones). The students make a bullet point plan for the
essay and post it as a reply. This works well as a revision strategy as the students can see how others have
approached the same task. Once everyone has posted their plan, you can start a discussion as to which
plans seem better and why. Creating a scale to use for rating the posts can be useful so that the students
can see how helpful other people think their effort were. (Note: At this time, there is no option to hide the
“Add new discussion topic” button, so you need to tell your students not to start discussion threads, but
to only reply to threads started by the teacher. If you only need one thread, then you can use the “a single
simple discussion” format and the “Add new discussion topic” button is not available to the students.)

Grading forums
The teacher can use the ratings scales to grade student activities in a forum. The methods are in
Forum settings under grades. There are 5 ways to aggregate ratings automatically to calculate
a forum grade for the Grade book. These include: Average, Max, Min, Count and Sum.

Forum ratings allow users to evaluate posts in a forum
Forum ratings use Scales to standardize the reporting of performance. A forum rating
can be included as part of a student’s grade. For example, a teacher might use a
custom rating scale in a forum and allow students to rate forum posts.
Forum ratings must be allowed and the potential rater must have role permission. Teachers by default have this ability.
The teacher role is also able to give permission to a student role in a specific forum to be able to assign a rating to a post.

How to use
Teacher view of a previously-rated student post

When rating is allowed, the qualified user will see “Rate this post” and a pull down menu after an entry (not their
own). The menu displays a scale that the forum creator selected in the Forum grade settings. The user can rate more
than one post at a time. When finished they should click the “submit my ratings” button at the bottom of the page.

AJAX forum rating
Forum rating can be made more user-friendly with the use of AJAX. Users can rate forum posts
almost instantly. AJAX forum rating needs to be enabled by in Settings > Site administration
> Appearance > AJAX and Javascript and by users in their user profile.
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Glossary activity
The glossary activity module allows participants to create and maintain a list of definitions, like a dictionary.
Glossary can be used in many ways. The entries can be searched or browsed in different formats. A glossary
can be a collaborative activity or be restricted to entries made by the teacher. Entries can be put in categories.
The auto-linking feature will highlight any word in the course which is located in the glossary.

ADDING A GLOSSARY
With the editing turned on, in the section you wish to add your glossary, click the “Add an
activity or resource” link (or, if not present, the “Add an activity” drop down menu ) and choose
Glossary. All settings may expanded by clicking the “Expand all” link top right.

General
General settings are expanded by default

Name
Give your new glossary a descriptive name.

Description
Describe the purpose of the glossary and provide instructions or background information, links etc. Click “Show
editing tools” to display the rich text editor, and drag the bottom right of the text box out to expand it.

Display description on course page
If this box is ticked, the description will appear on the course page just below the name of the glossary.

Is this glossary global?
Administrators can make a global glossary, with entries linking throughout the whole Moodle site. Any course
may contain a global glossary, though the best practice is to place a global glossary on the site front page.

Glossary type
Here you can decide whether the glossary will be main or secondary. The glossary system allows you
to export entries from any secondary glossary to the main one of the course. In order to do this, you
should specify which glossary is the main one. You can only have one main glossary per course.

Entries
Entries settings expanded

Approved by default
If set to “yes” then new entries appear automatically. If not,
then the teacher must approve each one first.

Always allow editing
If set to “yes”, students can edit their entries at any time. If not, then they can only
edit for a certain period (defined by an administrator in Site Policies)
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Duplicate entries allowed
This allows the entry of more than one definition for a given word.

Allow comments on entries
Students and teachers can leave comments on glossary definitions. The comments
are available through a link at the bottom of the definition.

Automatically link glossary entries
If the Glossary auto-linking filter is enabled by an administrator, then turning this
on allows individual entries in this glossary to be automatically linked whenever
the concept words and phrases appear throughout the rest of the same course.
This includes forum postings, internal resources, week summaries and so on.

••

The screen shot shows an auto-linked word in a forum

Note: Enabling linking for the glossary does not automatically turn on linking for each entry - linking needs
to be set for each entry individually. If you do not want particular text to be linked (in a forum posting, say)
then you should add <nolink> and </nolink> tags around the text. Note that category names are also linked.

Appearance
(These settings are collapsed by default)

The screen shot shows the Appearance settings expanded

Display format
That specifies the way that each entry will be shown within the glossary. The default formats are:
••Simple, dictionary style - This looks like a conventional dictionary with separate entries. No authors are displayed and
attachments are shown as links.
••Continuous without author - Like the simple style. Shows the entries one after other without any kind of separation
but the editing icons if your theme supports it.
••Full with author - A forum-like display format showing author’s data. Attachments are shown as links.
••Full without author - A forum-like display format that does not show author’s data. Attachments are shown as links.
••Encyclopaedia - Like ‘Full with author’ but attached images are shown inline.
••Entry list - This lists the concepts as links.
••FAQ - Useful for displaying lists of frequently asked questions. It automatically appends the words QUESTION and
ANSWER in the concept and definition respectively.

Approval display format
It is possible to set an alternative display format for when entries are approved that can differ from the display
format on the course page. This could be useful for instance if a tutor wants to see who made a particular glossary
entry before approving it but doesn’t want the students’ name to be displayed for others on the course page.

Entries shown per page
Decide here how many entries to show per page.

Show alphabet links
If set to “yes”, users can browse the glossary by letters of the alphabet.
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Show ‘ALL’ link
If set to “yes”, users can browse all the entries at once

Show ‘Special’ link
If set to “yes”, users can can browse the glossary by special characters, such as @ and #.

Allow print view
This provides a printer-friendly version link for students. (Teachers are
always provided with a printer-friendly version link.)

RSS
These settings are collapsed by default and only visible if RSS
has been enabled on the site and for the glossary.

RSS feed for this activity
This turns RSS on or off. When set to “None,” the RSS feed is disabled. When set to “Concepts with authors,”
the RSS feed will send out the glossary entries with the name of the author. When set to “Concepts
without authors,” the RSS feed sends out glossary entries without the name of the author.

Number of RSS recent articles
This number sets the number of entries that go out via RSS. If this number is set to 5, then the 5 most
recent articles will be sent to subscribers. As new entries get added, the oldest entry gets replaced on
the RSS feed. If your glossary gets a lot of posts every day, you will want to set this number high.
When RSS is enabled for your glossary, an orange RSS button appears on the main page (in the upper
right-hand side). When a user clicks on the RSS button, they see the XML code displayed, needed by
the news-reader. Once a user has the RSS news-feed link, adding it to a reader is simple and will then
display Glossary aggregated information, along with other information they subscribe to.

Grade
This setting is collapsed by default. Choose the category in which this glossary will appear if ratings are enabled.

Ratings
This setting is collapsed by default. The screen shot shows the Ratings settings expanded

Roles with permissions to rate
Glossary entries can be rated using a scale. By default, only teachers can rate glossary entries, though
students can be given permission to do so if desired from Administration>Glossary administration. This is a
useful tool for giving students participation grades. Any ratings given are recorded in the grade book.

Common module settings
These settings are collapsed by default. See the section on Common module settings.
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Restrict access/Activity completion
These settings are collapsed by default. The Restrict access and Activity completion settings
are visible if Conditional activities and Activity completion have been enabled in the site
and the course. Se the section on Conditional activity and Restricting access.

Glossary permissions
Role permissions for the activity can be changed in Settings > Glossary administration > Permissions.

USING A GLOSSARY

Adding a glossary entry:
••When you first create a glossary, click “Save and display” to be taken to the
“Add a new entry” screen.
••Alternatively, click on the glossary link and click the “Add a new entry” button
in the centre of the screen or the Administration block.

••Enter the word you want to define in the Concept text field.
••Add the definition of the word or concept.
••If you want to add an attachment, such as a picture or an article, you can
either drag/drop it or click the “Add” button to upload via the File picker

••You can add or edit categories by clicking the “Browse by category” tab:

Browse by category tab
••If there are synonyms you want to include with the entry, add them to the Keyword(s) text area. Enter one word per
line.
••Select the auto-linking options (see below) and save the changes.

This entry should be automatically linked
If site-wide glossary auto-linking has been enabled by an administrator and this is
set to “yes”, the entry will be automatically linked wherever it appears.

This entry is case sensitive
This setting specifies whether matching exact upper and lower case is necessary when
performing automatic linking to these entries. If this is turned on, then a word like “html”
in a forum posting will NOT be linked to a glossary entry called “HTML”.

Match whole words only
If automatic linking is enabled, then turning this setting on will force only whole words to be linked. For
example, a glossary entry named “construct” will not create a link inside the word “constructivism”.
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Editing glossary entries and Adding categories
Categories may be created to help organize your glossary entries. If you’ve enabled auto
linking, the category names can be linked along with individual entries.

To create a glossary category:
••Click the “Browse by category” tab in the main page of the glossary.
••Click the “Edit categories” button on the left side of the page.
••Click the “Add category” button on the resulting Categories page.
••Give the category a name.
••Choose whether you want the category name auto linked as well.
••Click the “Save changes” button.
If you auto link the category name, any occurrence of those words will be linked. When a student
clicks on the link, they will be taken to the “Browse by category” page of the glossary.

Browse options
You can browse glossaries according to the following options
••Browse by alphabet
••Browse by category (if there are any categories added)
••Browse by date (you can sort entries by last update or by creation date)
••Browse by author

Search options
You can also search for a given word using the Search field. Checking the ‘Search full text’ option (on the right
side of the Search box) allows searching for a given word in any position in the text. This can take longer and
return more entries than you might wish, but it is thorough. If you do not check the “Search full text” box, the
search only looks for the term names. The index below lets you browse the glossary according to a given letter.

Waiting approval
If entries require teacher approval before being publicly posted, this is where those entries are approved.

Printing a glossary
At the top right of the main glossary page, you’ll see a little printer icon. If you click the icon, Moodle will
open a new browser window and present all the words and definitions in a printer-friendly format.
To print the glossary:
••Click the printer icon at the top of the main glossary page.
••From the newly opened window, choose Print from the File menu of your browser.
••Once the word list has printed, close the printer-friendly format window.

••

Note: Teachers are always provided with a printer-friendly format link. To enable students
to print a glossary, set “Allow print view” to Yes on the edit glossary page.

Glossary comments
If you enabled comments on the glossary entries, users can annotate
the definitions in the word list. When you look at a word in the glossary
list, you’ll see a blue “Comments” link in the lower left-hand corner:
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When you click the link, a comments box opens up. Add your comment then click the “Save changes” button.
Once you’ve saved your comment, Moodle will display all of the comments for the
entry. When you return to the main glossary page, you’ll see a new message next to the
speech balloon telling you how many comments there are for the entry.

Exporting glossary entries to another glossary
Glossary entries can be exported and then imported into another glossary.
••In Settings > Glossary administration > Export entries click the “Export entries to file” button.
••Save the automatically generated XML file on your computer.
When the entries are imported into another glossary, the user performing
the import will be listed as author of all the entries.

••

Tip: A copy of a glossary may also be made by backing up the activity. To include glossary entries
in the backup, ‘Include enrolled users’ must be ticked in the initial backup settings. When the
glossary is restored, the authors of the entries will be the same as in the original glossary.

Exporting glossary entries to a portfolio
Users with permissions to export glossary entries to a
portfolio such as Mahara or Google Docs can do this via the
export icon at the bottom of each glossary entry:

Importing glossary entries
Glossary entries can be imported via XML file in Settings
> Glossary administration > Import entries.

••Click the “Choose a file” button and browse for the exported entries XML file on your computer
••Select the destination for the new entries: either the current glossary or a new one
••If you want to import category information, click the checkbox.
••Click the “Submit” button.
You’ll then see a report of the entries and categories added to the glossary. If you enabled
duplicate entries when you created the glossary, the import process will add all of the new
definitions. Otherwise, it will not allow you to import any duplicate entries.
You will be listed as author of all the entries.
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REASONS TO USE A GLOSSARY
While a basic glossary is important, creatively applying the glossary can really make an impact on your class.

Collaborative glossaries
Instead of creating a glossary on your own, why not have the students create them as they encounter unfamiliar
terms? A collaborative glossary can serve as a focal point for collaboration in a course. Each member of the class
could be assigned to contribute a term, a definition, or comments on submitted definitions. Multiple definitions
can be rated by you and by the students, with the highest-rated definitions accepted for the final class glossary.
When students are responsible for creating the definitions, they are much more likely to
remember the word and the correct definition. Engaging in the process of learning, debating, and
refining a glossary can go a long way toward helping students begin using new terms.
You can also structure multiple glossaries over the course of a semester. Break them
up by unit, chapter, week, or any other organizational structure.
If you have a large class, assign student teams to come up with definitions and answers. One strategy
for managing large courses is to make each team responsible for one week’s worth of definitions,
while all the other teams must rate and comment. Alternatively, each team could be responsible
for one definition per chapter and then rate and comment on the other teams’ work.

Credit for word use
This is a combination strategy using the forum and the auto-linking feature of the glossary. After you
and your students have defined the glossary terms, it’s important for students to begin practising using
the words in realistic contexts. Students, however, are usually reluctant to experiment with new terms.
With the auto-linking feature, it’s easy to spot when a glossary word has been used in a forum or in a
posting on the web site. To encourage word use, assign a portion of the credit students receive for their
forum postings for correct use of glossary terms. As you or other students rate posts, you can quickly
scan for highlighted glossary words and award points for usage. You may even want to break the score
down further. Perhaps award one point for using the word and two points for using it correctly.

Simple peer assessment
Have students add pieces of work with descriptions to a glossary and allow their classmates to
comment on each others’ entries to create a basic framework for peer assessment. While this
can be done more thoroughly in a Workshop, a glossary is a fast and effective solution.

Turning off links to glossary terms
In places such as forum posts and quizzes, terms will be automatically
highlighted and linked if they are in the glossary. Sometimes, this may be
unwanted. To avoid this on a case-by-case basis, click on the blue Filters link
in the activity’s Settings block. There you will be able to turn off the glossary
auto-linking feature for that particular activity while keeping it enabled elsewhere on the course:
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Question bank
A Question Bank allows a teacher to create, preview, and edit questions in a database of question categories.
The categories can be limited to being used on the site, course or quiz level. The questions in a category
can be added to a Quiz or to a lesson activity via an export process. The teacher enters the question bank
by creating or editing a quiz activity or via Settings > Course administration > Question bank.

SELECT A CATEGORY
Questions are organised into categories. You can imagine a question category
as a folder on your desktop computer. Then, questions are stored in these
categories in a similar way as your files are stored in a file system.
Each category must have a name and you can include a short description of the
category. You can create a category hierarchy. For example, you can specify a parent
category for each category or the ‘Top’ as the parent, when a category has no parent.

••

Tip: Creating question categories and sub categories is a good practice. It is better than keeping
all your questions in one big list in the quiz module. The hierarchy feature enables you to separate
categories into sub categories and sub categories into sub sub categories etc. indefinitely.
Categories and sub categories, etc., are very powerful when combined with random questions
that can select either from one category or from a category or any of its sub categories.

Initially each course has only one category called “Default”. It is good practice to create more categories
to organize your questions. This not only makes it easier to find questions, but makes the use of random
questions and matching question easier. You can create a hierarchy of categories because you can create
subcategories inside parent categories. To add or edit categories click on the “Categories” tab.
The question editing screen shows the questions from the currently selected category. You
choose this category from the Category: drop-down menu. Using the tick box below that
menu you determine whether to also show the questions from all subcategories.

CATEGORIES ARE SHARED IN CONTEXTS
We can share questions in different contexts. Context may be an unfamiliar
word. Think of a context as an area within your Moodle site. Each different
context has a separate question category hierarchy. So, now you can choose the
‘context’ within which your questions will be shared. And also an administrator
can give their users different permissions within different context areas.
See the diagram illustrating the relationship of the different contexts below.
Different colours denote different context types (though there are two hues of
green, both denote the same type). Notice how question contexts contain each
other. Notice also that Course category contexts can be nested. In this example
we have two contexts nested within each other ‘Humanities’ and ‘Languages’. We
could have a third course category ‘English’ and fourth and so on. Course categories can be nested infinitely and so you
can set up a very flexible system of question contexts for sharing questions and assigning question sharing permissions.
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Questions are stored in a hierarchical structure similar to folders at the file system. You can imagine question
context as a place where the tree of question categories is actually placed. By default, every teacher can
create new questions in the course context (the blue one in the diagram) and the activity module context
(the white one). We will discuss how to allow a teacher to create questions in higher contexts below.

Example diagram of question contexts: question categories can be stored in several nested areas
Question contexts are just as a subset of the Roles and Permissions contexts. A context contained
by another context inherits the permissions of the containing context. You can access question
categories in any containing context if you have permission to do so. Remember, you can access
the question bank in two ways: from within an activity (now only the quiz activity), or from the link
in the Course admin menu to ‘Questions’. When you access the question bank from the :
••Activity. If you have permissions you can access question categories in :
••that activity’s context and containing contexts.
••the course in which the activity module is contained.
••the course categories in which the course that contains the activity module is contained.
••the core system context.
••Course. If you have permissions you can access question categories in :
••that course.
••the course categories in which the course is contained.
••the core system context.

So questions contexts are accessible as follows :
••Activity context : questions only available to one activity module.
••Course context : questions available to all activity modules in a course and within the course from the ‘Questions’ link
in the course administration block.
••Course category contexts : questions available to all activity modules and courses in the course category (remember
one course category can contain other course categories, you can share your questions in any parent course category).
••Core System context : questions available in all courses and activities on your site.
All Question capabilities are tested in the relevant context. So, for example, to add a question to a category
you must have the add capability for that context. See roles and capability help for more info. If you don’t
have permission to do anything in a context, then the categories in that context will not be visible to you.
There are separate question category trees in each different ‘context’ in which questions are shared. The contexts
available to you depend on whether you access the question bank from an activity or from a course and depend on
the permissions assigned you for access to questions. See Question contexts for more information on these contexts.

CATEGORY SET UP AND MANAGEMENT
••Open the question bank.
••Either click on the Questions link in the ‘Administration’ block click on the ‘Questions’ link.
•• Or open the Editing a quiz page - when logged in as a teacher or someone with
appropriate permissions open a quiz and then click on the ‘Edit’ tab.
•• Click on the ‘Categories’ tab.
•• Below the list of current categories you will see a form to add a new category.
•• Choose the ‘parent’ category in which your new category will be placed. See image
of ‘Parent’ selector image on the left.
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Question category selector
••Placing your category in another category makes it a sub-category of the parent.
••Choosing ‘Top’ means that your category is a top level category, not a sub category. When more than one sharing
context is available you can place your category as a top level category in any of the contexts.
••Notice you can choose to make your category a ‘top level’ category in any context (see Question contexts) that
is available to you. Or you can choose to add your category as a sub category of another category in the same
context.e
••Type the name of your new question category in the text box.
••Add an optional meaningful description in the category info area.
••Click the ‘Add Category’ button. Your new question category will appear in the list of current categories.

Deleting Categories
Categories can also be created or deleted at will. However, if you try to delete a category containing
questions, then you will be asked to specify another category to move them to. You cannot delete
or move the last category in any context, there must always be one category in a context.

Using Arrow Icons for Moving Categories
You can also arrange the categories in a hierarchy so that they are easier to manage.
••The up/down arrow icons lets you change the order in which category ‘peers’ are displayed.
••The up / down icons are also used to move a top-level category between contexts. If you move a category to be the
first or last category in a context and then press the arrow key again then it will be moved to the next context.
••The right arrow icon allows you to move a category to be a child category of the category listed immediately above
it.
••The left arrow icon allows you to move a category up one category level (to be a peer of it’s parent category).
See the tool tip that appears when you place the mouse pointer above these icons if
you’re not sure what action an icon will perform. You cannot move the last category in
any context, there must always be at least one category left in all contexts.

Add a new question
••Click the Questions tab to access the Question Bank page, if not there already.
••From the Category drop-down menu, select a category you want to add a question to.
••The page will change to show the questions already in that category
••Select the question type you want to create from the Create new question drop-down menu.
••Fill in the form for the question type you are creating. Each question type has its own form and has its own options.
••Click Save Changes at the bottom of the form.
••Preview, Edit, Delete, and Move
The first column in the list of questions contains a number of icons and a selection box.
Clicking on the Preview icon will open a preview window in which you can test the question. The
Edit icon allows you to edit the question via the same form that you used to create it. The Delete
icon deletes the question, provided it is not already in use in some activity. The selection box allows
you to select a subset of questions that you can then move to another category using the controls
below the list of questions. The move icon allows you to move one question at a time.
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••Put the answer into the question name so you can quickly see the answers when students are asking for answers.
This is especially useful if you’re dealing with large sets of questions! (No option yet for viewing category or answer of
question in the list of questions.)
••Export questions in GIFT or Moodle XML formats, then import them into a Lesson. (Future versions of Moodle will
make Question bank available to both Lesson and Quiz activities.)
••Remember that while some of the same question types can be found in both the Quiz and Lesson modules, they can
be very different. Scoring and grading each student’s choice is more robust in a Quiz. On the other hand, each Lesson
question answer also has a jump associated it.
••Use GIFT or other export modes to print questions and answers in a category. Hint, clever use of word processor
macros, using search and replace, can tidy up a GIFT file for printing.
••The question title is useful in sorting and making notes. For example, “ZZ remove 2010-3 Why did the Moodler cross”,
will put this question at the bottom of the list. Or where you want a ‘the’ questions in a category to appear in a specific
order, use letters or numbers, knowing that AA will come first, AB will be second in the list.
••Do a copy and paste from a PDF file into the question content area. Reduces “other” hidden code which Word, Open
Office and other programs can insert.

SHARING AND MANAGING QUESTION BANKS
Be default, teachers can manage only the questions in the context of the courses they are in.
You can set up a role to allow teachers to share and manage questions on a larger scale.
You can also use this role to create a special system-wide “Question bank Manager” instead of
giving admin level or site-wide Manager access to a person managing the Questions.

Question Categories
A question category can contain individual questions or other question categories.
They can be found by using the Question bank or when building a quiz.
You can imagine a question category as a folder on your desktop computer. Then, questions
are stored in these categories in a similar way as your files are stored in a file system.
Each category must have a name and you can include a short description of the category.
You can create a category hierarchy. For example, you can specify a parent category for
each category or the ‘Top’ as the parent, when a category has no parent.

••

Tip: Creating question categories and sub categories is a good practice. It is better than keeping
all your questions in one big list in the quiz module. The hierarchy feature enables you to separate
categories into sub categories and sub categories into sub sub categories etc. indefinitely.
Categories and sub categories, etc., are very powerful when combined with random questions
that can select either from one category or from a category or any of its sub categories.

Question Sharing
You can share questions in several different contexts. Sharing categories in the ‘System’ context or
‘Course’ context has a similar effect to publishing the category so others can see them or hiding a
question category from specific users. See the Question contexts page for more information.

••

By default a course teacher cannot see or use any Question context above the course level.
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Questions
QUESTION BEHAVIOURS
Deferred feedback
Students must enter an answer to each question and then submit the entire
quiz, before anything is graded or they get any feedback.

Adaptive mode and Adaptive mode (no penalties)
Students are allowed multiple attempts at the question before moving on to the next one. The question can
adapt itself to the student’s answer, for example by giving some hints before asking the student to try again.

Manual grading
Used for essay questions (irrespective of what the quiz is set to) but you can now
choose to have every question in the quiz manually graded, if you wish.

Interactive mode
After submitting one answer, and reading the feedback, the student has to click a ‘Try again’ button
before they can try a new response. They can be given hints to help them. Once the student has got
the question right, they can no longer change their response. Once the student has got the question
wrong too many times, they are just graded wrong (or partially correct) and get shown the feedback and
can no longer change their answer. There can be different feedback after each try the student makes.
The number of tries the student gets is the number of hints in the question definition plus one.

Immediate feedback
Similar to interactive mode in that the student can submit their response immediately during the quiz
attempt, and get it graded. However, they can only submit one response, they cannot change it later.

Deferred feedback or Immediate feedback with Certainty-based marking (CBM)
With CBM, the student does not only answer the question, but they also indicate how sure they
are they got the question right. The grading is adjusted by the choice of certainty, so that students
have to reflect honestly on their own level of knowledge in order to get the best mark.

••

Managing question behaviours

An administrator can manage question behaviours available across the site in Administration >
Site administration > Plugins > Question behaviours > Manage question behaviours.

QUESTION TYPES

Multiple Choice
Moodle provides teachers with a lot of flexibility when creating this common question type. You can
include pictures, sound or other media in the question or answer options (by inserting HTML) and
weight individual answers. Remember that Lesson module questions behave differently.
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There are two types of multiple choice questions - single answer and multiple answer.

Single-answer questions
These questions allow one and only one answer to be chosen by providing radio buttons next to
the answers. You will specify non-negative marks for each answer, usually zero marks for wrong
answers, maximum marks for correct answers and partial marks for partially correct answers.

Multiple-answer questions
The teacher can select “multiple answers are allowed” in a Multiple Choice question type. “Multiple answers”
questions types in a quiz allow one or more answers to be chosen by providing check boxes next to the answers.
Each answer may carry a positive or negative grade, so that choosing ALL the options will not necessarily
result in good grade. If the total grade is negative then the total grade for this question will be zero.
Feedback can be associated either with specific answers, or with the question as a whole.

Question set-up
••Select the question category
••Give the question a descriptive name. You’ll use the name to track your questions later so “Question 1” isn’t a good
idea. The name will be used in the question lists on the quiz editing page or in the lesson as a page title. It will not be
shown to the students, so you can choose any name that makes sense to you and possibly other teachers.
••Create the question text. If you’re using the HTML Editor, you can format the question just like a word processing
document.
••Select an image to display if you want to add a picture to the question. The available images are those you have
uploaded to the main Moodle files area (they cannot be in folders). For the student, the image appears immediately
after the question text and before the answer options.
••Alternatively, if you used the HTML editor to create the question text, you can click the image icon. This will pop up the
Insert Image window. You can choose to upload an image into your files area from this window, or you can add the
URL of an image on the web. If you add a file to your files area, click the name of the file after you upload it to insert
the link into the URL text entry at the top of the screen. Then click OK.
••Set the ‘default question grade’ (i.e. the maximum number of marks for this question).
••Set the ‘Penalty factor’.
••If you wish, add general feedback. This is text that appears to students after they have answered the question.
••Choose whether students can only select one answer or multiple answers
••Choose whether to shuffle the answer options
••Write your first answer in the Choice 1 text field. Inserting HTML into this area also makes it possible to add an image
or a sound file.
••Select a grade percentage for the answer. This is the percentage of the total points for the question that selecting
this response is worth. You can select negative percentages as well as positive percentages. So, selecting a correct
response in a multiple answer question may give you 50% of the possible points, while selecting a wrong answer may
take away 10%. Note that in a multiple-answer question, the grades must add up to 100%.
••If you wish, you can add feedback for each response. It may be a bit more work, but it’s good practice to tell the
students why each answer is right or wrong using the feedback area. If students know why an answer is right or
wrong, they can analyse their own thinking and begin to understand why an answer is correct. Your feedback will only
be displayed if you select Show Feedback in the quiz body options.
••Fill in the rest of the response choices in the rest of the form. Any unused areas will be ignored.
••If you wish, fill in the overall feedback fields.
••Select the “Save Changes” button at the bottom of the screen.

Penalty factor
The ‘penalty factor’ only applies when the question is used in a quiz using adaptive mode - i.e. where
the student is allowed multiple attempts at a question even within the same attempt at the quiz. If the
penalty factor is more than 0, then the student will lose that proportion of the maximum grade upon
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each successive attempt. For example, if the default question grade is 10, and the penalty factor is
0.2, then each successive attempt after the first one will incur a penalty of 0.2 x 10 = 2 points.

General feedback
General feedback is some text that gets shown to the student after they have attempted
the question. Unlike feedback, which depends on the question type and what response
the student gave, the same general feedback text is shown to all students.
You can control when general feedback is shown to students using the
“Students may review:” check-boxes on the quiz editing form.
You can use the general feedback to give students some background to what knowledge the question was
testing. Or to give them a link to more information they can use if they did not understand the questions.

Overall feedback
The option overall feedback for correct/partially correct/incorrect responses is particularly useful for multipleresponse questions, where it is difficult to control what feedback students see just using the answer-specific feedback.
So, when the student submits the question, they will see the answer-specific feedback
next to the option(s) they selected, the overall feedback in a box below the options,
and if applicable, the general feedback underneath everything else.

Lesson module multiple choice questions
This page was created for the Quiz module. A Lesson Multiple Choice or Multianswer question
type looks the same to the student but is very different in the teacher’s edit mode. A lesson
question offers the teacher the chance to both grade a student’s answer, give feedback and
also to send the student to another specific page based upon the student’s choice.
There are other differences. Quiz has a more robust scoring system that is similar to “Custom
Scoring” in the Lesson module. Even with custom scoring turned on, Lesson will not give
percentage credit of a question’s score for an answer. And students must select all the correct
answers to receive any credit for the multi-answer question in the Lesson module.

True/false
A student is given only two choices for an answer in this kind of question: True
or False. The question content can include an image or html code.
When feedback is enabled, the appropriate feedback message is shown to the student after the answer. For example,
if the correct answer is “False”, but they answer “True” (getting it wrong) then the “True” feedback is shown.

Question setup
••Select the question category
••Give the question a descriptive name - this allows you to identify it in the question bank.
••Enter a question in the ‘question text’ field.
••Select an image to display if you want to add a picture to the question. For the student, it appears immediately after
the question text and before the choices.
••Set the ‘default question grade’ (i.e. the maximum number of marks for this question).
••Set the ‘Penalty factor’.
••If you wish, add general feedback. This is text that appears to the student after he/she has answered the question.
••Select the correct answer - true or false.
••Finally, provide feedback for each of the answers ‘true’ and ‘false’.
••Click ‘Save changes’ to add the question to the category.
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Penalty factor
The ‘penalty factor’ only applies when the question is used in a quiz using adaptive mode - i.e. where
the student is allowed multiple attempts at a question even within the same attempt at the quiz. If
the penalty factor is more than 0, then the student will lose that proportion of the maximum grade
upon each successive attempt. For example, if the default question grade is 10, and the penalty factor
is 0.2, then each successive attempt after the first one will incur a penalty of 0.2 x 10 = 2 points.

Matching
Matching questions have a content area and a list of names or statements which must be correctly
matched against another list of names or statements. For example “Match the Capital with the
Country” with the two lists “Canada, Italy, Japan” and “Ottawa, Rome, Tokyo”. In the Quiz Module,
each match is equally weighted to contribute towards the grade for the total question.

Question set-up
••Select the question category
••Give the question a descriptive name - this allows you to identify it in the question bank.
••Enter some instructions in the ‘Question text’ field to tell the students what they are matching.
••Set the ‘Default mark’ (i.e. the maximum number of points for this question).
••If you wish, add general feedback. This is text that appears to the student after he/she has answered the question.
••Check the ‘shuffle’ box if you want the answers in the drop-down menus to be shuffled. Note: The Quiz display setting
must also be set to shuffle within questions for this to work.
••For the first matching item, enter the question and a matching answer.
••Fill in at least two questions and three answers. Click ‘Blanks for 3 more questions’ to add more. You can enter as many
as 10 items (or more). You can provide extra wrong answers by giving an answer with a blank question.
••Set the ‘Penalty for each incorrect try’ (see Grading).
••Click Save changes to add the question to the category.

Grading
••Each sub-question is equally weighted to contribute towards the grade for the total question. For example a student
who correctly matches 3 of the 4 possible matches will receive 3/4 or 75% of the total possible score for that question.
••The ‘penalty factor’ only applies when the question is used in a quiz using adaptive mode - i.e. where the student is
allowed multiple attempts at a question even within the same attempt at the quiz. If the penalty factor is more than
0, then the student will lose that proportion of the maximum grade upon each successive attempt. For example, if the
default question grade is 10, and the penalty factor is 0.2, then each successive attempt after the first one will incur a
penalty of 0.2 x 10 = 2 points.

Repeated entries
It is possible to have repeated entries in one of the lists but care should be taken to
make the repeats identical. For example “Identify the type of these creatures” with
the lists “Ant, Cow, Dog, Sparrow” and “Insect, Mammal, Mammal, Bird”.

Ordered questions
In the Quiz module, it is possible for both the question list and the answer list to be shuffled.
The answer list is always shuffled. The “shuffle within questions” must be “Yes” as a quiz setting
under Display AND the shuffle question box must be check on the individual question.
Consider the question “Match the letter with its position in the alphabet” with the question list
“1, 2, 3, 4” and answer list “A, B, C, D”. The answer list is always shuffled for each student in the pull
down list of the possible matches. However, only when both the quiz and individual question
shuffles are turned on, will the question list be shuffled to something like “2,4,1,3”.
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Matching questions look better on screen if you put the longer piece of text in the question and not the match.
For example, when vocabulary matching, put the single word in the match and the definition sentence in
the question. Otherwise the drop down for long questions will be awkward to use and difficult to read.

Embedded answers (Cloze) questions
These questions consist of a passage of text (in Moodle format) that has various answers
embedded within it, including multiple choice, short answers and numerical answers.
There is currently no graphical interface to create these questions within your Moodle site - you need
to specify the question format using the text box or by importing them from external files.
You can link to an external web site that does create these questions from a graphical
interface, see the Online Cloze Question quiz generator below.

Question set-up
••Select the question category
••Give the question a descriptive name - this allows you to identify it in the question bank.
••Enter the passage of text (in Moodle format - see Format below) into the ‘question text’ field.
••Select an image to display if you want to add a picture to the question. For the student, it appears immediately above
the question text.
••Set the ‘default question grade’ (i.e. the maximum number of marks for this question).
••Set the ‘Penalty factor’ (see Penalty factor below).
••If you wish, add general feedback. This is text that appears to the student after he/she has answered the question.
••The editor has been modified and allows you to test if your syntax is good. The different questions elements decoded
will be displayed and syntax errors pinpoint. However, it cannot check if the question decoded is two questions in one
because of an error syntax.
••Click Save changes to add the question to the category.

Penalty factor
The ‘penalty factor’ only applies when the question is used in a quiz using adaptive mode - i.e. where
the student is allowed multiple attempts at a question even within the same attempt at the quiz. If
the penalty factor is more than 0, then the student will lose that proportion of the maximum grade
upon each successive attempt. For example, if the default question grade is 10, and the penalty factor
is 0.2, then each successive attempt after the first one will incur a penalty of 0.2 x 10 = 2 points.

Question rendering
The question answer INPUT HTML ELEMENT ( Short and Numerical) or SELECT HTML
ELEMENT (multichoice) are normally displayed in-line with the text.
The size of INPUT HTML ELEMENT ( Short and Numerical) will be adjustable to the length of
the longest answer (good or bad) + a random number (0 to 15% total length).
The size will adjust to the length of the student response when displayed in the grading and feedback process.
The size of the SELECT HTML ELEMENT (multichoice) adjusts itself automatically to the longest answer. Format
Questions consist of a passage of text (in Moodle format) that has various sub-questions embedded within it, including
••short answers (SHORTANSWER or SA or MW), case is unimportant,
••short answers (SHORTANSWER_C or SAC or MWC), case must match,
••numerical answers (NUMERICAL or NM),
••multiple choice (MULTICHOICE or MC), represented as a dropdown menu in-line in the text
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••multiple choice (MULTICHOICE_V or MCV), represented a vertical column of radio buttons, or
••multiple choice (MULTICHOICE_H or MCH), represented as a horizontal row of radio-buttons.
All question items within a cloze-type question are coded inside curled braces { }
The number which appears between the opening brace and the colon {1: is the weighting of
that item; if it is set at 1 for all the items, it needs not be specified, so you can have {:
After the colon we have the item question type: MULTICHOICE, SHORTANSWER, NUMERICAL
The syntax for MULTICHOICE and SHORTANSWER is the same; the only
difference is in the displaying of the item to the student
The order of the various answers is indifferent (except if you want a catch-all for wrong answers, see #12 below)
A correct answer is preceded with the equal sign = or a percentage (usually %100%)
- Note: The equal sign (=) doesn’t seem to work with SHORTANSWER.
A wrong answer is preceded with nothing or a percentage (usually %0%)but you can even
use negative points by preceding with ~%-25% [not before Moodle 2.0])
You can allocate some points between 0 and 100 to some answers, if you put the appropriate percentage
All answers except the first one are separated from one another by the tilde ~ sign
Answers can be followed by an optional feedback message, preceded with the # sign; if there
is no feedback message, the # sign can be present or absent, it does not matter
In the SHORTANSWER type you may want to put a catch-all (wrong) answer in order to send a “wrong, try
again” feedback; you can do this by inserting an asterisk * as the very last expected answer in your formula
In the MULTICHOICE question type the answers are automatically scrambled

A simple example:
{1:SHORTANSWER:=Berlin} is the capital of Germany.
NB: Be careful when copying a cloze type question into the WYSIWYG HTML editor,
as line breaks tend to get added, which destroys the question.

A longer example
The following text creates a simple embedded-answers question:
Match the following cities with the correct state:
* San Francisco: {1:MULTICHOICE:=California#OK~Arizona#Wrong}
* Tucson: {1:MULTICHOICE:California#Wrong~%100%Arizona#OK}
* Los Angeles: {1:MULTICHOICE:=California#OK~Arizona#Wrong}
* Phoenix: {1:MULTICHOICE:%0%California#Wrong~=Arizona#OK}
The capital of France is {1:SHORTANSWER:%100%Paris#Congratulations!
~%50%Marseille#No, that is the second largest city in France (after
Paris).~*#Wrong answer. The capital of France is Paris, of course.}.
And the result will be:
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Short Answer
In a short answer question, the student types in a word or phrase in response to a question (that
may include an image). Answers may or may not be case sensitive. The answer could be a word or a
phrase, but it must match one of your acceptable answers exactly. It’s a good idea to keep the required
answer as short as possible to avoid missing a correct answer that’s phrased differently.

Question setup
••Select the question category
••Give your question a descriptive name.
••Create the question text. If you’re using the HTML Editor, you can format the question just like a word processing
document.

••

Tip: if the answer is intended to fill a gap in the text, use underscores (5 or more) to indicate where the gap is.

Select an image to display if you want to add a picture to the question (see
step 4 in Multiple Choice question type for more detail).
••Set the ‘default question grade’ (i.e. the maximum number of marks for this question).
••Set the ‘Penalty factor’ (see Penalty factor below).
••If you wish, add general feedback. This is text that appears to the student after he/she has answered the question.
••Choose whether the answers are case-sensitive. Case sensitivity can be tricky where capitalization is important. Will
you accept Ban Ki-moon as well as ban ki-moon as an answer?
••Next, fill in the answers you will accept. You could give common misspellings partial credit with this option. For
example will you accept “Ban Ki moon”? Use wildcards to allow for variants on a word or phrase.
••Add grade for each answer.
••Create feedback for any and all answers. This will appear if the student enters that answer.

••

Note: It is good practice to add a single wild card * for the last answer, so you can create
a feedback response and a score for all other answers students might have.

••Click Save Changes to add the question to the category.

Penalty factor
The ‘penalty factor’ only applies when the question is used in a quiz using adaptive mode - i.e. where
the student is allowed multiple attempts at a question even within the same attempt at the quiz. If
the penalty factor is more than 0, then the student will lose that proportion of the maximum grade
upon each successive attempt. For example, if the default question grade is 10, and the penalty factor
is 0.2, then each successive attempt after the first one will incur a penalty of 0.2 x 10 = 2 points.

Wildcard usage
You can use the asterisk character (*) as a wildcard to match any series of characters. For
example, use ran*ing to match any word or phrase starting with ran and ending with ing.
If you really do want to match an asterisk then use a backslash like this: \*
If you want one question with the two answers fuel and oxygen, you ought to be able to limit the number of
variants by writing fuel*oxygen 100%. This would accept “fuel oxygen”, “fuel, oxygen”, “fuel; oxygen”, “fuel and
oxygen”, “fuel & oxygen” “fuel oxygen”, “fuel und oxygen” “fuel&&oxygen”. It would even accept “fuel or oxygen”,
“fuel but not oxygen” “fuel|oxygen” which might not be so good but you can never be completely safe!
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Here are some answers and scores for a question “What does a rocket burn?”.
••oxygen*fuel with a score 100%
••*fuel* with a score 50%
••*oxygen* with a score 50%
••*air* with a score 40%
••* with a score of 0%
The order of the answers is important. The answers are evaluated from 1st to last. When a match is found the process
stops. If no match is found the question is scored wrong and the general response is used. It is a good practice to
put a wild card as the last answer so the evaluation process knows what to do when nothing above it matches.
Without wildcards, the answers are compared exactly, so be careful with your spelling!

Feedback for wrong answers
When you wish to have short answer type questions, you naturally have a limited number of variations that would
be acceptable. So in case you wish to give a feedback in case of a wrong answer, you must spell out the right answers
exactly and then use * as a final answer which will have grade as zero, and feedback will be the one for wrong answer.
Effectively, ANYTHING other than the specific answers mentioned by you will be treated as this option due
to wildcard and will be deemed wrong; it’ll give 0 marks and show the feedback for a wrong answer.
Here is an example:
What is a rabbit?
answer1: animal
feedback: right
grade: 100%
answer2: mammal
feedback: right
grade: 100%
answer3: vertebrate
feedback: right
grade: 100%
answer4: *
feedback: ouch! that was wrong
grade: none
Remember: you cannot do negative marking in this type and ANYTHING other than your right answer
will be treated as option 4 due to the wildcard and given that feedback and zero marks.

••

Tip: Prototype your short answer questions to catch common acceptable answers you hadn’t thought of.
Start out by creating a few acceptable answers, then include the question in a quiz for no points. Be sure to
tell students you are testing a new question. Once the quiz is over, review students’ answers and add their
acceptable answers to the list.
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Essay
The essay question type is intended for short answers of a paragraph or two, that one often finds on exams.
For longer essays, the Online text assignment or the Upload a single file assignment are better choices.

Question set-up
••Choose a category
••Give the question a descriptive name - this allows you to identify it in the question bank.
••Enter the question in the ‘question text’ field
••Select an image to display if you want to add a picture to the question. For the student, it appears immediately after
the question text.
••Set the ‘default question grade’ (i.e. the maximum number of marks for this question).
••Add ‘General Feedback’ if required. This is text that appears to the student after the question is graded.
••Set an input box size to indicate the length of answer expected.
••Allow attachments if required.
••Add information for graders as appropriate.
••Click Save changes to add the question to the category.

Creating a response template
When using the Essay question type, you can set a template which appears in
the students’ text editor to help them scaffold their response:
Response template in question set up screen

What the student sees

Question grading
The essay question will not be assigned a grade until it has been reviewed by a teacher
and manually graded. Until that happens, the student’s grade will be 0.
To grade a student’s answer in a quiz, follow the ‘manual grading’ link under quiz results in
the navigation block. When manually grading an essay question, the grader is able to enter
a custom comment in response to the essay and assign a score for the essay.

Numerical
From the student perspective, a numerical question looks just like a short-answer
question. The difference is that numerical answers are allowed to have an accepted
error. This allows a fixed range of answers to be evaluated as one answer.
For example, if the answer is 30 with an accepted error of 5, then any
number between 25 and 35 will be accepted as correct.
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You are able to
••grade independently the number and the unit,
••choose to handle the unit response either as
••a text input element or as
••a multichoice radio element,
••just grade the number with the option to write the unit close to the input element,
••put the unit either
••at right of the number as the most common occurrence
••or at left as in $ 100,00.
Furthermore your valid number formats and specific instructions on how to
answer will be put near the answer input element. An example
Numerical multiple choice unit example
Questions may have different answers with different levels of accuracy. That
lets you create questions like “What is a root of x^2 - 3x + 2?” and award
different levels of credit depending on the accuracy of the answer.
Text answers are no longer allowed - Short-Answer
question type should be used instead.

Question set-up
In Quiz or Question bank
••Select the question category
••Give the question a descriptive name - this allows you to identify it in the question bank.
••Enter a question in the ‘question text’ field. This can include an equation - Moodle has a couple of text filters that
allow you to type an equation and have it properly typeset when displayed. The Algebra filter is very good for writing
common mathematical expressions in a simple way. More complicated expressions may be written using the TeX filter.
Filters contain information for administrators on how to enable these filters. Alternatively, select an image to display if
you want to add a picture to the question.
••Select an image to display if you want to add a picture to the question. For the student, it appears immediately after
the question text and before the choices.
••Set the ‘default question grade’ (i.e. the maximum number of marks for this question).
••Set the ‘Penalty factor’ (see Penalty factor below).
••Add general feedback. This is text that appears to the student after he/she has answered the question.
••Now enter the first accepted answer(s). Note: Floating point numbers, e.g. 23.4, may also be written as 23,4 or 2.34E+1.
••Enter an accepted error for this answer. This is the range above or below the answer that Moodle will accept as a
match. For example, if the correct answer is 5, but you will accept 4 or 6 as answers, your accepted error is 1.
••Enter a grade for this answer.
••Enter feedback for the accepted answer. This is the text that the student will see if they enter a number within the
accepted error of the answer.
••Repeat for each of the answers you want to accept. You can provide feedback for all wrong answers by using a
wildcard, i.e. the asterisk character (*), as an answer with grade ‘None’.
••Units can also be specified. For example, if you enter a unit of ‘cm’ here, and the accepted answer is 15, then the
answers ‘15cm’ and ‘15’ are both accepted as correct. You can also specify a multiplier. So, if your main answer was 5500
with unit W, you can also add the unit kW with a multiplier of 0.001. This means that the answers ‘5500’, ‘5500W’ or
‘5.5kW’ would all be marked correct. Note that the accepted error is also multiplied, so an allowed error of 100W would
become an error of 0.1kW.
••Click ‘Save changes’ to add the question to the category.
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Penalty factor
The ‘penalty factor’ only applies when the question is used in a quiz using adaptive mode - i.e. where
the student is allowed multiple attempts at a question even within the same attempt at the quiz. If
the penalty factor is more than 0, then the student will lose that proportion of the maximum grade
upon each successive attempt. For example, if the default question grade is 10, and the penalty factor
is 0.2, then each successive attempt after the first one will incur a penalty of 0.2 x 10 = 2 points.

Description
A Description question page simply shows some text (and possibly graphics)
without requiring an answer. It is more of a label than a question type.

••

TIP: When shuffling questions is turned off, this type of page can provide
information to be used with a following group of questions.
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Quiz activity
Creating a new quiz is a two-step process. In the first step, you create the quiz activity and set
its options which specify the rules for interacting with the quiz. In the second step you add
questions to the quiz. This page describes the options you can set for the quiz activity.

QUIZ ADMINISTRATION
To create a quiz, choose Add an activity or resource > Quiz, (or, if you don’t have this link, use the dropdown Add
an activity>Quiz). You will be offered the following settings, which can be changed later in the Edit Settings link
of the Quiz administration settings block. All settings may expanded by clicking the “Expand all” link top right.

General
General settings
expanded by default

Name
This is the standard name
field. This name will appear
on the home page of the
course, navigation menu
and other places which
will show or provide
links to this quiz.

Description
Describe the purpose of the glossary and provide instructions or background information, links etc. Click “Show
editing tools” to display the rich text editor, and drag the bottom right of the text box out to expand it.

Display description on course page
If ticked, the quiz description will appear on the course page directly under the quiz name.

Timing
(These settings are
collapsed by default)

Open the quiz
You can specify times when the quiz is accessible for people to make attempts. Before the opening time the
quiz will be unavailable to students. They will be able to view the quiz introduction but will not be able to view
the questions. Quizzes with start times in the future display both the open and close date for students.
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••

Note: You can make the quiz available at different times for different groups or users in
the Group or User override sections of the Quiz Administration settings block.

Close the quiz
After the closing time, the students will not be able to start new attempts. Answers that the
student submits after the quiz closing date will be saved but they will not be marked.
Even after the quiz has closed students will still be able to see the quiz description and review their attempts.
What exactly they will see depends on the settings you choose for review options (see below).

Time limit
By default, quizzes do not have a time limit, which allows students as much time as they need to complete the quiz.
If you do specify a time limit, several things are done to try and ensure that quizzes are completed within that time:

Navigation block showing quiz timer
••

A countdown timer is shown in the quiz navigation block

••
When the timer has run out, the quiz is submitted automatically with whatever
answers have been filled in so far
••
If a student manages to cheat and goes over the allotted time, no marks are awarded
for any answers entered after the time ran out

Note: You can make the quiz available last a different period of time for different groups or users in
the Group or User override sections of the Quiz Administration settings block (see below).

When time expires…
There are three options as to what will happen when the time limit
is up. Choose the one you need from the dropdown menu:

Timing options
If you select “there is a grace period...” then you can check the box to enable the “Submission grace period”
and specify a period of time during which learners may still submit the quiz after the time is up.
Examples of how timing is handled
••A student starts a quiz at noon. The quiz has a one-hour time-limit, and a 1 hour delay between attempts. The student
gets distracted, and so actually does not submit (using the overdue handling) until 1:30 pm. They are allowed to start
their second attempt at 2.00 pm.
••The quiz count-down timer submits a student’s quiz attempt at the last second when time expires. Because the server
is heavily loaded, it takes 30 seconds to process the student’s attempt. The submission is accepted nonetheless.
••Same situation as above but with a 120 second delay: The submission is rejected.
••The delay is not because of server load but because the student found a way to cheat the timer. Moodle cannot know
what causes a delay.The behaviour is controlled by the admin setting(quiz | graceperiodmin), 60 seconds by default.
••A student is a member of 3 groups,all of which have different override settings. Which limits will apply to this student?
If there is any user-specific override, then that is used, and the group overrides for that setting are not used at all.
Otherwise, if there are multiple group overrides, the most generous values are used (the earliest open date, the latest
close date, the longest time limit, the most number of attempts, and the student can type any of the passwords).
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Grade
These settings are collapsed by default.

Grade category
If you have categories in your grade book, select the one you wish the quiz to be in here.

Attempts allowed
Students may be allowed to have multiple attempts at a quiz. This can help make the process of taking
the quiz more of an educational activity rather than simply an assessment. If the quiz is randomized
then the student will get a new version for each attempt. This is useful for practice purposes.

••

Note: You can change the allowed number of attempts for different groups or users in
the Group or User override sections of the Quiz Administration settings block.

Grading method
When multiple attempts are allowed, there are different ways you can use
the grades to calculate the student’s final grade for the quiz.
••Highest grade - the final grade is the highest (best) grade in any attempt
••Average grade - the final grade is the average (simple mean) grade of all attempts
••First grade - the final grade is the grade earned on the first attempt (other attempts are ignored)
••Last grade - the final grade is the grade earned on the most recent attempt only..

Layout
These settings are collapsed by default.

Question order
If ‘Shuffled randomly’ is selected, then the order of questions in the quiz will be randomly shuffled each time a student
starts a new attempt at the quiz. The intention is to make it a little harder for students to copy from each other.

New page
For longer quizzes it makes sense to stretch the quiz over several pages by limiting the number of questions per
page. When adding questions to the quiz, page breaks will automatically be inserted according to the setting you
choose here. However, you will also be able to move page breaks around by hand later on the editing page.

••

Note that changing this setting has no effect on questions you have already added to the quiz. The setting
will only apply to questions you add subsequently. To change the page breaks in an existing quiz, you need
to go to the quiz editing screen, tick the ‘Show page breaks’ checkbox, then use the repaginate control.

Navigation method
(available by clicking Show More) By choosing Sequential instead of Free, the teacher is forcing the student to
progress through the questions in order without being able to go back to a previous question or skip to a later one.
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Question behaviour
These settings are collapsed by default.

Shuffle within questions
If set to ‘yes’, then each time the student takes a quiz the parts of the question will be shuffled randomly.
How questions behave
••Deferred feedback - Students must enter an answer to each question and then submit the entire quiz, before anything
is graded or they get any feedback.
••Adaptive mode and Adaptive mode (no penalties) - Allows students to have multiple attempts at the question before
moving on to the next question. The question can adapt itself to the student’s answer, for example by giving some
hints before asking the student to try again.
••Interactive mode - After submitting one answer, and reading the feedback, the student has to click a ‘Try again’ button
before they can try a new response. Once the student has got the question right, they can no longer change their
response. Once the student has got the question wrong too many times, they are just graded wrong (or partially
correct) and get shown the feedback and can no longer change their answer. There can be different feedback after
each try the student makes.
••Immediate feedback - Similar to interactive mode in that the student can submit their response immediately during
the quiz attempt, and get it graded. However, they can only submit one response, they cannot change it later.
••Deferred feedback or Immediate feedback with Certainty-based marking (CBM) - With CBM, the student does not only
answer the question, but they also indicate how sure they are they got the question right. The grading is adjusted by
the choice of certainty, so that students have to reflect honestly on their own level of knowledge in order to get the
best mark. See the See Also section below for an example quiz using CBM and a blog post explaining the philosophy.

••

Note: There is also an option “Manual grading” which can be enabled from Administration>Site
administration>Plugins>Question behaviour. This causes all questions in the quiz to require manual grading.

Certainty-based marking
When a student answers a question they also have to state how sure they are of the answer: not very (less
than 67%); fairly (more than 67%) or very (more than 80%). Their grading is then adjusted according to how
certain they are, which means that for example if they answered correctly but were only guessing, their mark
is adjusted from 1 to 0.33. If they answered wrongly but were very sure, their mark is adjusted from 0 to -2.
Correct answer; very sure			

Correct answer; fairly sure

Correct answer; not very sure		

Wrong answer; very sure		
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Each attempt builds on the last
(available by clicking “Show more”) If multiple attempts are allowed and this setting is set to Yes, then each
new attempt contains the results of the previous attempt. This allows the student on the new attempt
to concentrate on just those questions that were answered incorrectly on the previous attempt. If this
option is chosen then each attempt by a particular student uses the same questions in the same order,
independent of randomization settings. To show a fresh quiz on every attempt, select No for this setting.

Review options
These settings are collapsed by default.
This section controls what information students will be shown
when they review their past attempts at the quiz, and during
the attempt in adaptive mode. It is a matrix with check boxes.
The various pieces of information that can be controlled are:

The attempt
Will show how the student responded to each question.

Whether correct
Displays whether the students response to each question is correct or incorrect.

Marks
Reveals the marks awarded to the student and the grade for the quiz.

Specific feedback
Will show the feedback for the response to the answer as set when adding the question to the quiz.
Each response to a question can have feedback for both correct and incorrect answers.

General feedback
Displays the general feedback for the whole question as set when adding the question to the quiz. You can
use the general feedback to give students some background to what knowledge the question was testing.

Right answer
Reveals the correct answer to each question, whether the student answered correctly or not (See note below).

Overall feedback
Displays feedback for the entire quiz as set in the quiz settings (See note below).
For each of the above items, you can determine the timeframe when the students will see them:

During the attempt
This is only available when ‘How questions behave’ has been set to ‘Immediate feedback’, ‘Immediate feedback
with CBM’ and ‘Interactive with multiple tries’. If set to one of these options then a ‘Check’ button will appear below
the answer and when clicked the student will submit that response and then receive immediate feedback.

Immediately after the attempt
‘Immediately’ means within 2 minutes of the student clicking “submit all and finish”.

Later, while the quiz is still open
‘Later’ means after 2 minutes, but before the close date (if the quiz does not have a close date, this phase never ends).

After the quiz is closed
This means what it says (you never get here for quizzes without a close date).
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••

Tip: Checking any of the boxes in the timeframe row will reveal the test to the student. For example, to
allow students to see their quiz immediately after taking it but not later, make sure none of the boxes in
“Later” or “After” rows are checked. The student will be able to see their grade but not get into the quiz.
Note: Currently, the Answers display is a bit inconsistent between different question types.
For example, the matching question type shows students which of their responses are
correct, but does not tell them the right answer for the ones they got wrong. The short answer
and multiple choices question types do tell the student what the correct answer is.

Users with the capability ‘View hidden grades’ moodle/grade:viewhidden (typically
teachers and administrators) are not affected by these Review Options settings and will
always be able to review all information about a student’s attempt at any time.
In your list of review options, you must have ‘The attempt’ (the first option in the lists) selected before you can
enable the options to show ‘Whether correct’, ‘Specific feedback’, ‘General feedback’, and ‘Right answer’. If you
choose not to let the students review the attempt, your only options are to display ‘Marks’ and ‘Overall feedback’.

Display
These settings are collapsed by default.

Decimal places in grades
This option determines how many digits will be shown after the decimal point when the grade
is displayed. A setting of 0 for example means that the grades are displayed as integers. This
setting is only used for the display of grades, not for the display or marking of answers.

Extra restrictions on attempts
These settings are collapsed by default and are
available by clicking “Show more”.

Require password
This field is optional.
If you specify a password in here then participants must enter the same password before they are allowed to
make an attempt on the quiz. This is useful to give only a selected group of students access to the quiz.

Require network address
This field is optional.
You can restrict access for a quiz to particular subnets on the LAN or Internet by specifying a comma-separated list of
partial or full IP address numbers. This is especially useful for a proctored (invigilated) quiz, where you want to be sure
that only people in a certain room are able to access the quiz. For example: 192.168. , 231.54.211.0/20, 231.3.56.211
There are three types of numbers you can use (you can not use text based domain names like example.com):

Compiled by www.HowToMoodle.com

127

••Full IP addresses, such as 192.168.10.1 which will match a single computer (or proxy).
••Partial addresses, such as 192.168 which will match anything starting with those numbers.
••CIDR notation, such as 231.54.211.0/20 which allows you to specify more detailed subnets.
Spaces are ignored.

Enforced delay between attempts
These two fields are optional.
You can set a time (from seconds to weeks) between the first and second attempt of a quiz. You can also (or
alternatively) set a time from seconds to weeks for subsequent attempts after the second attempt. Thus,
you might allow a student to take the quiz twice immediately with no delay, but if they want to improve
their score with a third attempt, they are forced to wait a week and use the time for extra revision.

Browser security
This is by default an advanced field, visible by clicking “Show advanced”.
The options in this section offer various ways to try to restrict how students may try to ‘cheat’ while attempting a quiz.
However, this is not a simple issue, and what in one situation is considered ‘cheating’ may, in another situation, just
be effective use of information technology. (For example, the ability to quickly find answers using a search engine.)

••

Note also that this is not just at problem of technology with a technical solution. Cheating has been going
on since long before computers, and while computers make certain actions, like copy and paste, easier, they
also make it easier for teachers to detect cheating - for example using the quiz reports. The options provided
here are not fool-proof, and while they do make some forms of cheating harder for students, they also make
it more inconvenient for students to attempt the quizzes, and they are not fool-proof.

Full screen pop-up with some JavaScript security
There is a limit to what the quiz, which runs on a web server, can do to restrict what the student sitting
at their computer can do while attempting the quiz. However, this option does what is possible:
The quiz will only start if the student has a JavaScript-enabled web-browser.
The quiz appears in a full-screen popup window that covers all the other
windows and has no course navigation controls.
Student view of quiz question with full screen popup.
The students are prevented, as far as is possible,
from using facilities like copy and paste.
This setting does not work well with the MyMobile theme
for mobile devices included in the standard installation. In
particular, quiz time limits do not function correctly.

Require the use of Safe Exam Browser
This option will only appear if your administrator has enabled it in Settings > Site
administration > Development > Experimental > Experimental settings.
Safe Exam Browser is a customised web browser that must be downloaded and installed on the
computer that the student uses to attempt the quiz. It restricts student use more effectively than
a pop up window option. Features include full screen, without web navigation options, shortcut
keys including copy and paste are disabled and of course surfing the web during an exam.
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Overall feedback
These settings are collapsed by default.
Overall feedback is shown to a student after they have completed an
attempt at the quiz. The text that is shown can depend on the grade
the student got. Click “Show editing tools” to display the rich text editor,
and drag the bottom right of the text box out to expand it.
For example, if you entered:
Grade boundary: 100%
Feedback: “Well done”
Grade boundary: 40%
Feedback: “Please study this week’s work again”
Grade boundary: 0%
Then students who score between 100% and 40% will see the “Well done” message, and those who score
between 39.99% and 0% will see “Please study this week’s work again”. That is, the grade boundaries define
ranges of grades, and each feedback string is displayed to scores within the appropriate range.
Grade boundaries can be specified either as a percentage, for example “31.41%”, or as a number,
for example “7”. If your quiz is out of 10 marks, a grade boundary of 7 means 7/10 or better.
Note that the maximum and minimum grade boundaries (100% and 0%) are set automatically.
You can set as many or as few grade boundaries as you wish. The form allows you up to 5 ranges
at first, but you can add more by clicking the “Add 3 fields to form” button underneath.
If you’re getting confusing error messages about a boundary being out of sequence (when
it’s obviously *in* sequence), or “boundaries must be between 0% and 100%” (and they are)
-- check that the Maximum Grade for this quiz is set to something greater than zero.

Common module settings
(These settings are collapsed by default) See Common module settings

Restrict access/Activity completion
(These settings are collapsed by default). The Restrict access and Activity completion settings are visible
if Conditional activities and Activity completion have been enabled in the site and the course.

Group and User overrides
Dates, timing and number of allowed attempts may be changed for
individual users or groups by following the links Group Overrides
or User Overrides in the Quiz Administration settings block.

Group overrides
To change a quiz setting for a particular group, click the “add group
override” button in Quiz Administration>Group overrides, make
the changes you wish and save or enter another override.
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User overrides
To change a quiz setting for a particular user or users, click the “add
user override “button in Quiz Administration>Group overrides, make
the changes you wish and save or enter another override.

••

Site administration settings

The quiz module has additional settings which may be changed by an administrator in
Administration > Site administration > Plugins > Activity modules > Quiz.
Autosave period (from Moodle 2.5) If enabled, student responses will be saved every minute/two minutes/five minutes
(according to selection). This is useful, because students don’t lose work, but it does increase the load on the server.
How questions behave can be configured in Administration>Site
administration>Plugins>Question behaviours>Manage question behaviours

BUILDING A QUIZ
Once you have completed the quiz administration, you can add questions from a number of locations.

Add a question
••Click the “Add question” button to begin a new question (1 below)
••Click “Show” (2a) to reveal the contents of the question bank (2b) and then choose a pre-made question or click
“Create new question” (3)
••Click “Add a random question” to add a random question, providing there are questions in the question bank already.

Creating a new question
•• To make a brand new question, click “Add a question”.
•• From the next screen, choose the question type you want to add and click
“Next”
•• Fill in the question form, making sure to give a grade to the correct answer.
•• Click “Save changes”
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A question when it has been created

Adding responses and feedback
From Moodle 2.5, when you add responses and feedback you can hide or display the text editor:
Without the editing tools

With the editing tools

••

You can continue adding questions this way, clicking
the “Add a question” button each time.

Note that when a question has been created, an icon and words display its type (eg
multiple choice) and a magnifying glass icon allows you to preview it.

Choosing a pre-made question
If you or other teachers in the course have made questions, or if there are
questions from an earlier quiz, you can add them to the current quiz.
Click the arrows next to the questions the question bank
(1 below) or check/tick the box of several.
Then click the button “add to quiz” (2). To ensure all previously
made questions are available, make sure to tick the boxes “also
show questions from sub-categories/old questions”.

Adding a random question
As long as you have questions in the question bank, you can add random questions to your quiz. This might be
useful if you have students in a class taking a quiz at the same time, because they are unlikely to get the same
questions at the same time. The same question will never appear twice in a quiz. If you include several random
questions then different questions will always be chosen for each of them. If you mix random questions with
non-random questions then the random questions will be chosen so that they do not duplicate one of the nonrandom questions. This does imply that you need to provide enough questions in the category from which
the random questions are chosen, otherwise the student will be shown a friendly error message. The more
questions you provide the more likely it will be that students get different questions on each attempt.

Compiled by www.HowToMoodle.com

131

The grade for the randomly chosen question will be rescaled so that the maximum
grade is what you have chosen as the grade for the random question.
You can add one or more random questions by choosing the number and category
in the question bank. Note the die icon to highlight random question selection.

Random question selected for quiz

Quiz layout
••You can choose in Settings>Quiz administration>Edit settings>Layout whether to have a new page for every question
or after a certain number of questions.
••You can click the “Add a page here” button to add a page at selected intervals and move questions up and down by
clicking the arrow button.
•• You can also set the pages by clicking the tab “Order and paging” on the Edit
quiz screen.
•• Questions may be moved up and down with the arrows, or you can check the
boxes to their left and then click “reorder questions”
•• You can check a box to select a question and then click “Add new pages after
selected questions”
•• You can “repaginate” by setting the number of questions per page. After
setting the number of questions per page, you can move questions so that there
are a different number of questions on each page.

Order and paging

Rpaginating

Assigning points to questions
Go to Settings > Quiz administration > Edit quiz > Editing quiz
Pre-made questions will have points already assigned to them. However, you can alter how many
points each question is worth within a quiz by changing the number in the box to the right of
each question (1). You can change the maximum grade by changing the number in the box at the
top of the quiz (2). The default is one point per question and 100.00 maximum grade.
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Points per question and max grade

••

Tip: Each save button is independent of each other. Thus if you change 2 grade boxes and click on
the “Save” button, only the grade next to that button will be saved. Your other changes will revert
to what they were before. Best practice is to change the grade and save one question at a time.

The quiz module will do any maths, so for example, a 2 point question will be worth 2 times more
when the Quiz module determines how many point out of 10 to award the student.

Previewing the quiz
••You can preview individual questions by clicking the magnifying glass icon.
••You can preview the whole quiz by clicking the “Preview” link in Settings>Quiz administration>Preview
••The quiz works like a real quiz so you can see your grades and any feedback for correct/incorrect answers just as a
student would see them.
Click to preview the whole quiz			

		

Previewing a single question

Quiz in preview mode

Quiz feedback for incorrect answer

After quiz has been attempted
If one or more students have taken the quiz, you will see a list of all the questions in
the quiz and a notice saying that you cannot add or remove questions.
You can change the order of questions, re-grade them, preview an individual question and click on a
question edit link that will allow you to directly edit the question stored in the question bank.
NOTE: You can delete all quiz attempts by students and then edit the quiz as if no students had
attempted it. To do this, click the quiz name and then the Results link in the Navigation block. This will
present a list of students and their scores. Click “Select all” and then “Delete selected attempts”.
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Manual Grading
The manual grading report may be viewed by clicking the quiz in question and then
accessing Administration> Quiz administration >Results > Manual grading
The first screen of the report lists all the questions in the quiz that need to be, or have been, manually graded
(for example essay questions) with the number of attempts. There is an option to also show the questions
that have been automatically graded, which is useful if you ever need to edit the grades by hand.
Needs grading opening screen

Preferences to display manual grading page

Example of student attempt ready for manual grading

Dealing with faulty questions
There are several ways to deal with “bad” questions in a quiz.
••Change the grade for the bad question to 0 in the quiz.
••Edit the question, changing what you will accept as a correct answer, then re-grading the exam. Remember, when you
change a question, the next time it is used the question will be as it was in the last edit. Also, re-grading will only affect
one quiz at a time.
••You can edit the question to explain the situation to the student and then you can set the grade for the question to
zero. After you make such changes you should re-grade the quiz by clicking on the Results tab and then the Re-grade
tab. This will change the grade for all students who have taken the quiz so far. Remember, if the question is used by
another quiz, your “explanation” will appear as part of that quiz.
••You can change the grade for the bad question and then move or delete the question from your question category.
The question will still appear on the quiz. Some places do not like to delete any question, but will move them to a
“dead” or “bad” question category.
••When you discover a bad question in your quiz, it may affect the question bank. Remember that a final might be made
up of a certain number of random questions drawn from different question categories, the same categories used in
a smaller subject quiz. It can be very important do something about bad or invalid questions in a question category
when the categories are use in other places.
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QUIZ REPORTS

Grades report
The quiz grades report may be viewed by clicking on the quiz and accessing
Administration > Quiz administration >Results > Grades.
It shows all the students’ quiz attempts, with the overall grade, and the grade for each question.
There are links to review all the details of a student’s attempt, just as the student would see it.
The results can be downloaded in a variety of formats.
There is a setting form at the top of the page that can be used to control what is displayed.
At the bottom of the page is a graph showing the distribution of scores.
There are check boxes to allow you to individually re-grade or delete the selected attempts.

Deleting attempts
The grading report can be used to delete selected quiz attempts, which may sometimes be necessary.

••

Note that you cannot edit the quiz after it has been attempted, so that
is one reason you may wish to delete all attempts.

Re-grading attempts
The grading report allows the teacher to select quiz attempts that need to be re-graded. The teacher can ‘dry-run’ a regrade. That is, see which scores would change if you did a real re-grade, but without actually updating the grades yet.

••

Warning: This function does not touch automatically graded questions. If you have accidently
set Question behaviour to “Manual grading”, then all questions, even those usually set to
automatically grade will not be automatically graded. Changing this setting to something
like Deferred feedback, and them clicking Re-grade will NOT change the state of the
ungraded Multi-choice questions etc. You need to manually grade all the questions.

Report options
••Which students/attempts
••Whether to show the individual question grades
••How many attempts per page

Report columns
••First name / Surname
••Started on - the date and time quiz was started
••Completed - the date and time completed
••Time taken - the amount of time it took the student to start and submit the quiz
••Grade/x - the number of points students scored; ‘x’ is the maximum number of points
••Feedback - any feedback remarks

Grades report page preference settings
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Grades report showing grades, feedback, start & end times

Grades report showing marks, grades, comments

Grades report chart

Display options
Show / download options:
••Participants who have attempted the quiz
••Participants who have not attempted the quiz
••All attempts - list all the students in the course, no matter if they took the quiz or not
••All Participants who have or have not attempted the quiz

Only show / download attempts check boxes for:
••That are graded for each user (Highest grade)
••That have been regraded / are marked as needing regrading

Report preferences
••Page size
••Show/download marks for each question

••

Tip: To sort the results by two columns, first click on the column heading you want to be the
second key, and then click on the column heading you want to be the primary key.

Responses report
The quiz responses report may be viewed by clicking on the quiz and then accessing
Administration > Quiz administration> Results > Responses
The quiz responses report allows the teacher to see a table of answers for a quiz, with a row for each student. For
example, it is possible to scroll down and see each student’s answer to the same question. Here are some examples:
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Preferences

Basic report, no preferences checked

Report example with 2 preferences checked

Statistics report
The quiz statistics report may be viewed by clicking on the quiz and then accessing
Administration > Quiz administration> Results > Statistics
This report gives a statistical (psychometric) analysis of the quiz, and the questions within it. The top
section of this report gives a summary of the whole quiz. The next section gives an analysis showing
all questions in a table format. There are links in this section to edit individual questions or drill
down into a detailed analysis of a particular question. The last section of this report is a bar graph of
the percentage of correct answers (Facility index) and the Discriminative efficiency index.
The full report (overview and detailed analysis of all questions) can be downloaded
in a variety of formats, as can the quiz structure analysis table.

Quiz information
This section gives some basic information about the test as a whole. You will see:
••Quiz name
••Course name
••Open and close dates (if applicable)
••Total number of first/graded attempts
••Average grade for first/all attempts
••Median grade
••Standard deviation of grades
••Coefficient of internal consistency, sometimes called Cronbach Alpha. This is a measure of whether all the items in the
quiz are testing basically the same thing. Thus it measures the consistency of the text, which is a lower bound for the
validity. Higher numbers here are better.
••Error ratio - the variation in the grades comes from two sources. First some students are better than others at what is
being tested, and second there is some random variation. We hope that the quiz grades will largely be determined by
the student’s ability, and that random variation will be minimised. The error ratio estimates how much of the variation
is random, and so lower is better.
••Standard error - this is derived from the error ratio, and is a measure of how much random variation there is in each
test grade. So, if the Standard error is 10%, and a student scored 60%, then their real ability probably lies somewhere
between 50% and 70%.
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Example of quiz information section

Quiz structure analysis
This section lists all the questions in the quiz with various statistics in a table format.
••Q# - shows the question number (position), question type icon, and preview and edit icons
••Question name - the name is also a link to the detailed analysis of this question (See Quiz Question Statistics below).
••Attempts - how many students attempted this question.
••Facility Index - the percentage of students that answered the question correctly.
••Standard Deviation – the variation of scores for the question.
••Random guess score - the score the student would get by guessing randomly
••Intended/Effective weight - Intended weight is simply what you set up when editing the quiz. If question 1 is worth 3
marks out of a total of 10 for the quiz, the intended weight is 30%. The effective weight is an attempt to estimate, from
the results, how much of the actual variation was due to this question. So, ideally the effective weights should be close
to the intended weights.
••Discrimination index - this is the correlation between the score for this question and the score for the whole quiz. That
is, for a good question, you hope that the students who score highly on this question are the same students who score
highly on the whole quiz. Higher numbers are better.
••Discriminative efficiency - another measure that is similar to Discrimination index.
Where random questions are used, there is one row in the table for the random question, followed by
further rows, one for each real question that was selected in place of this random question.
When quiz questions are randomized for each quiz, the quiz module determines a default position.

Example of statistics structural analysis section

Quiz statistics chart example
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Quiz question statistics
Use Navigation > quiz’s name > Results > Statistics (click on any question title). It is possible to see the
statistics for one question on a single page. This view will also tell you what percentage of quiz takers
selected each answer (Analysis of responses) and give you basic information about the question.
••Question information- The basic information about the question, the name of the quiz, the question, the question
type, the position in the quiz and the question itself. There are preview and edit icons in this page.
••Question statistics - This repeats the information from the table row from the Quiz structure analysis that relates to this
question.
••Report options - You can choose whether to run the report on all attempts, or just the first attempt by each student.
Some of the calculations used in the report are based on assumptions that may not apply to quizzes that allow more
than one attempt.

••

Tip: Computing the statistics takes some time. The report will store the computed values
and re-use them for up to 15 minutes. Therefore, there is a display of how recently the
statistics were calculated, with a button to recalculate them immediately.
Individual question page preferences

Individual question information

Individual question’s statistic information

Analysis of individual question responses
This gives a frequency analysis of the different responses that were given to each part of
the question. The details of the analysis depends on the question type, and not all question
types support this. For example, essay question responses cannot be analyzed.
Individual question’s responses statistic information
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SCORM activity
SCORM (Sharable Content Object Reference Model) is a collection of specifications that enable interoperability,
accessibility and reusability of web-based learning content. SCORM content can be delivered to learners
via any SCORM-compliant Learning Management System (LMS) using the same version of SCORM.
The Moodle SCORM module enables you (the teacher) to upload any SCORM or AICC package
to include in your course. SCORM 1.2 is supported in Moodle but SCORM 2004 is not.
Note: Moodle does not generate SCORM content. Moodle presents the content of SCORM
packages to learners, and saves data from learner interactions with the SCORM package.

ADDING A SCORM PACKAGE

Quick method:

••

Notes: The ‘Quick method’ does not work with Internet Explorer,
and cannot yet be used to add AICC packages.

••Click the ‘Turn editing on’ button at the top right of the course page
••Drag and drop the SCORM package zip file onto the course section where you’d like it to appear
••Answer ‘Add a SCORM package’ to the popup dialogue asking what you want to do with the zip file then click the
upload button
••If necessary, edit the title of the file by clicking the pencil icon, or edit other options (see below) by clicking the editing
icon

Longer method:
••Click the ‘Turn editing on’ button at the top right of the course page
••Click the ‘Add an activity or resource’ link in the section you wish to add your SCORM package, then in the activity
chooser, select SCORM package then click the Add button (or select ‘SCORM package’ from the ‘Add an activity’
dropdown menu)
••Enter a name and a description (which may be required or optional according to the admin settings)
••Either drag and drop a SCORM package zip file into the box with an arrow or click the Add button to open the File
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picker menu in order to choose a file from your computer or a repository
••Select display and other options as required (see below)
••Click the button ‘Save and display’ at the bottom of the page
You can edit or update the SCORM package later by clicking on the edit icon (usually a hand/pen)
or by clicking on its name and then Settings > SCORM/AICC administration > Edit settings.

COURSE SETTINGS

General
General settings expanded by default

Name
Whatever you type here will
form the link learners click on
to access the SCORM package,
so it is helpful to give it a name
that suggests its purpose.

Description
Add a description of your
SCORM activity here. Click
“Show editing tools” to display
the rich text editor, and drag
the bottom right of the text
box out to expand it.

Display description on the course page
If this box is ticked, the description will appear on the course page just below the name of the SCORM activity.

Package
This setting determines what SCORM package is used by this SCORM activity. To select the SCORM package, first
select the Choose button to launch the File picker or drag and drop your SCORM package into the box as below:
Package settings are
expanded by default

Alias/Shortcut - from Moodle 2.6
If you access your SCORM package
from a repository (such as File system
repository or Private files) you can
choose to create an alias/shortcut to it
and then set an update frequency to
set how often Moodle should check
to see if there is an updated zip. (See
Working with files for more information
on setting an alias/shortcut.)
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Selecting an imsmanifest.xml - from Moodle 2.6
It it possible to select the imsmanifest.xml file and have it as an alias/shortcut. To do this, you need to have created
a File system repository and, when configuring it, allowed relative files. Extract your SCORM package into a folder
there. When clicking on the Add button to add your SCORM package, select the file system repository folder with
your SCORM package and browse for and select the imsmanfest.xml file, ensuring you the option to create an alias/
shortcut to the file. Save and display. (Note this method is only currently supported by the File system repository.)

••

Note: The settings (Type, URL and Auto-update frequency) are only available
when configured globally. See Administration settings below.

Appearance
These settings are collapsed by default.

Display package
Choose from current or new window. Note
that if you choose a new window, students
need to ensure pop ups are enabled.

Display course structure
on entry page
If this is enabled then the table of contents
of the package will be displayed when the
students clicks to access the package.

Hide navigation buttons
Display attempt status
You can choose whether to display a
summary of the student’s attempts on
the entry page, on their My home page
or both. This setting is helpful when
debugging grading issues - working
out why a user got a certain grade.
The following settings become visible
when “Show more” is clicked:

Width
Stage size width as a css value, either %
or pixels. Default is 100%. You can change
to a different percentage by putting a %
symbol after the number (ex. 80%). You
can also set to a pixels value by entering
a number higher than 100 (ex. 800).

Height
Stage size height as a css value, either % or pixels. Default is 500 pixels. You can change to a percentage by putting a %
symbol after the number (ex. 80%). You can also set to a pixels value by entering a number higher than 100 (ex. 800).

Options
There is a series of check boxes for:Allow the window to be resized ad scrolled,
displaying directory links, location bar, menu bar, toolbar and/or status.
••Student skip content structure page - never, first access, always
••Disable preview mode - If this option is set to Yes, the Preview button in the view page of a SCORM/AICC Package
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activity will be hidden. The student can choose to preview (browse mode) the activity or attempt it in the normal
mode. When a Learning Object is completed in preview (browse) mode, it’s marked with browsed icon
••Display course structure in player

Availability
These settings are
collapsed by default.
Choose here the
dates you wish the
SCORM package
to be available
to students.

Grade
These settings are collapsed by default

Grading method
••Learning Objects - This mode shows the number of completed/passed Learning Objects for the activity. The max value
is the number of Package’s Learning Objects. Tip: If your SCORM package does report cmi.core.lesson_status, and does
not report cmi.core.score.raw, then you should use this setting.
••Highest grade - The grade page will display the highest score obtained by users in all passed Learning Objects. Tip: If
your SCORM package does report cmi.core.score.raw, and does not report cmi.core.lesson_status, then you should use
this setting, Average grade, or Sum grade.
••Average grade - If you choose this mode Moodle will calculate the average of all scores.
••Sum grade - With this mode all the scores will be added.

Maximum grade
Not applicable if Grading Method is Learning objects. Usual setting is 100. If your SCO ‘s high score is
something other than 100, you should adjust this value appropriately. When grading Method is one
of the score settings, then the gradebook grade is package score divided by this number.
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Attempts management
These settings are collapsed by default.

Number of attempts
Defines the number of attempts permitted to users.
It works only with SCORM 1.2 and AICC packages.
SCORM2004 has its own max attempts definition.
•• The option to start a new attempt is provided by
a checkbox above the Enter button on the content
structure page, so be sure you’re providing access
to that page if you want to allow more than one
attempt.
••An attempt is not complete until the cmi.core.lesson_status for the attempt is set to either ‘completed’ or ‘passed’. After
that, the Start new attempt checkbox is available to the learner.

Attempts grading
When you permit multiple attempts for students, you can choose how to record
the result in gradebook by first, last, average or highest settings.
Display attempt status - If enabled, scores and grades for attempts are displayed on the SCORM
outline page. This setting makes the block display more info to the user on the entry page to the
SCORM and in the course overview block - if you turn it off it will display less info. This setting is
helpful when debugging grading issues - working out why a user got a certain grade.

Force new attempt
If this is enabled then every time the student accesses the package, it will count as a new attempt.

Lock after final attempt
If this is enabled then once a student has used up all their attempts, they can no longer access the SCORM package.

Compatibility settings
These settings are collapsed by default.

Force completed
If this is enabled then the status of the current attempt is
set to “complete”. Note that this only applies to SCORM 1.2
packages and is useful if the SCORM package does not handle
revisiting an attempt correctly, in review or browse mode,
or otherwise incorrectly issues the completion status.

Auto-Continue
If Auto-continue is set to Yes, when a Learning Object calls the “close communication” method, the next available
Learning Object is launched automatically. If it is set to No, the users must use the “Continue” button to go on.

••

Tip: Auto-Continue will only to move from one SCORM to the next in the same topic.

Auto-update frequency
If not using a standard SCORM package uploaded using the filepicker and the SCORM package is hosted
outside your Moodle installation the option to auto-update the package will be available - you can
elect to have the package updated on every entry to the package or daily via the Moodle cron.
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Common module settings
See Common module settings

Restrict access
These settings will be available if Conditional activities are enabled.

Activity completion settings
If activity completion has been enabled for the course, then SCORM completion
may be set based on minimum score or status (e.g. “Passed”).

Save settings
As in most activities there are 3 save button choices:
••Cancel, Save and return to course and Save changes.
••The Save changes button will take the teacher back to the SCORM “stage” page.

SITE ADMINISTRATION SETTINGS

••

These options are available to the site administrator in Site
administration > Plugins > Activity Modules > SCORM Package.

Default Value Settings
Many of the settings available in the SCORM Package administration simply
set the default value for the SCORM activity module setup options provided
within courses. Edit these settings to save yourself time when adding large
numbers of packages, or to establish a standard for presentation across the site.
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Other Important Settings
The following options provided which do not simply set a default value for the SCORM activity editing page view.

Auto-update frequency
If not using a standard SCORM package uploaded using the filepicker and the SCORM package is hosted
outside your Moodle installation the option to auto-update the package will be available - you can
elect to have the package updated on every entry to the package or daily via the Moodle cron.

Synchronization time
Enable external package type
If selected, this presents a text field to paste a URL to a remote imsmanifest.xml (in an unzipped remote SCORM
package), as well as the file picker option provided by default. Note that the content is played from the designated
location, and not unpacked into the Moodle file system. So if the base url is different from your Moodle url then browser
security will block cross-domain communication and no grades/tracking information will be passed back to Moodle.

Enable downloaded package type
If selected, presents a text field to paste a URL to a remote package.zip SCORM package.
Package is downloaded and unzipped into the Moodle file system.

Enable IMS package type
Enables a package to be selected from within an IMS repository

Force users to enable JavaScript
Since the SCORM API uses JavaScript to save data to Moodle, this is a great idea!

Activate API debug and tracing (set the capture mask with apidebugmask)
This turns on debugging for SCORM activities. In Moodle 2 you no longer
have to also turn on debugging in the developer options.

API debug capture mask
.* will debug for admin user only: You can use the mask to enable debugging under certain conditions. For example,
if you are logged in using the admin user (username admin) you can set the api mask to: admin.* Users not logged
in as admin will not see the debugging log. The “Default” api mask is .* which translates roughly to everybody.

Enable direct AICC url
Makes it easier to connect to externally hosted AICC content as the teacher doesn’t have
to create an AICC package and is able to link directly to the external AICC url.

Enable external AICC HACP
The SCORM activity can also support external AICC HACP Communication where the AICC package
is hosted on an external content providers site and passes back http requests directly from the
external server instead of within the users web browser session - this is disabled by default.

USING SCORM
Like a Moodle course, each SCORM package will vary with the modules used in its construction
by the teacher and by the SCORM activity settings established by the teacher.

••

Features of student view

••Preview and review mode options
••Checkboxes to indicate whether sections have been accessed previously
••Start new attempt and Reset
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SCORM reports
A teacher can access 3 report types for the SCORM activity via the reports tab:
••Basic report
••Graph report (new in Moodle 2.3)
••Interactions report

Basic report
The basic report page shows a table of attempts for the SCORM activity. If you have the SCORM activity
set up to allow multiple attempts, there may be more than one attempt for some users.
Selected attempts may be deleted by ticking the checkboxes then clicking the ‘Delete selected attempts’ button.
The basic report may be downloaded in ODS, Excel or text format.

A detailed report of each user’s attempts may be obtained by clicking on the number in the attempts column.
The track details link provides information on specific SCORM values recorded in Moodle by the SCORM object.
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••

Note that the tracked details depend heavily upon what the SCORM object itself is
programmed to report. Many SCORM packages created with authoring suites use
the suspend_data field to record important information, instead of the traditional
SCORM values. This makes deciphering the recorded data extremely difficult.

Graph report
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The graph report displays graphs of percentage obtained against number of participants.

SCORM interactions report
The interactions report shows students’ responses to questions together with the correct answers.

SCORM and the Gradebook
Some SCORM packages report both cmi.core.lesson_status and cmi.core.score.raw. Others report only cmi.core.
lesson_status, or only cmi.core.score.raw. The Grading Method setting for SCORM objects is meant to account for that.
If you have the Grading Method set to Highest grade, Average grade, or Sum grade, and the learning object does
not report a score, only, cmi.core.lesson_status, then there will be no numerical score to pass to the gradebook.
If your SCORM packages do not report cmi.core.score.raw, then the best Grading Method setting is
Learning Objects. This reports either a 1 or a 0 as a score for each learning object. The gradebook
value for that SCORM activity is the percent of scos in the package for which learners got a 1.
On the other hand, if your SCORM packages do not report a lesson_status, then select one of the score-based
Grading Method options, such as Highest grade, Average grade, or Sum grade, and not Learning Objects.
If you do not know what your SCOs are reporting to the LMS, then run them through to completion with debugging on.
Much of the way SCORM objects are graded is controlled inside the SCORM Authoring process
before it is packaged for use in Moodle. Make sure all your grading settings are set correctly.
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Wiki activity
ADDING A WIKI
With the editing turned on, in the section you wish to add your wiki, click the “Add an activity or
resource” link (or, if not present, the “Add an activity” drop down menu )and choose Wiki.
This will take you to the wiki settings page titled “Adding a new wiki”. All settings
may expanded by clicking the “Expand all” link top right.
In an existing wiki, the wiki settings can be found in Administration > Wiki administration > Edit settings.

General
(General settings are
expanded by default)

Wiki name
The name you give to your
wiki here will appear as the
link on the course page for
your students to click.

Wiki description
Explain the purpose
of your wiki here. (This
description may or may not
be compulsory depending
on your admin’s settings.)

Display description
on course page
If this box is checked, then the description you added above will appear with the wiki link on the course page.

Wiki mode
Either “Individual wiki” where each student gets their own. Only the student
and the teacher, or non-editing teacher can see or use that wiki.
Or “Collaborative wiki” where students work together on a single wiki, which
teachers and on-editing teachers can also see and use.

First page name
The name you add here will form the first page of your new wiki. It is a required
field and once a name has been entered, it can’t be changed.
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Format
(These settings are collapsed by default)

Default format
Set the default type of editing your wiki will use. Choose from
HTML - editing using the normal text editor
Creole - a popular wiki editing language.
If this is selected, a small editing toolbar will appear.

NWiki - a wiki editing language used in the contributed NWiki module.

Force format
If you check this box then students cannot choose their own method of editing the wiki.

Common module settings
Restrict access/Activity completion
Locally Assigned Roles
USING A WIKI

Creating the first page

Once the wiki is set up, a user will click the link and reach this screen:

Adding more pages
Type the name of your page inside double brackets. (1 in screenshot left). You can
preview it by clicking the “preview” button towards the bottom of the screen.
Press the “save” button.
Now click the (red) link for one of the pages (2 in screenshot left)
and you will be prompted to create it in the same way you create
the first page: Once created, a page has a blue link.
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••

Tip If you use the New option from the navigation block you will still need to copy and
paste the name of the new page onto the immediate parent page and surround it with
double brackets. This creates a link to your new page and makes it accessible from the
main Wiki page. Otherwise nobody will recognise the so called lost new page.

Wiki editing in general
Depending on the type of the wiki, there are several ways to edit your page. But don’t worry: The best thing of a
wiki is, that nothing is lost. The old version will be there - and if someone changes your version of the page - your
version will also be there. Note that the options for editing, commenting viewing history, map and files may all be
accessed both from tabs at the top (1 in screenshot below) and links in the navigation block (2 in screenshot below):

View
The View tab at the top or link in the navigation block allows users to display and view the wiki page.

Edit
The Edit tab at the top or link in the navigation block allows users to edit the wiki page.

Comments
The Comments tab at the top or link in the navigation block allows users to see and add comments about the wiki.

History
The History tab at the top or link in the navigation block allows users to see what has been altered in the wiki.
Compare edits by clicking the “Compare Selected” button.
Click the “Restore” button of the version you wish to restore if the latest edit is unsuitable:

Map
The Map tab at the top or link in the navigation block allows users to view areas of the wiki such as a list of pages (as
in the following screenshot), updated or orphaned pages etc. (Orphaned pages are pages not linked to anywhere.)
To select what you want to see, click the Map menu dropdown box.

Files
The Files tab at the top or link in the navigation block allows users to
access any files which have been added to the wiki.
By default, the Teacher role can add and manage files to the Files tab, but the Student
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role can only view them. You could change this though with a permissions override to the
Manage wiki files capability (mod/wiki:managefiles) in any particular wiki.

Administration
The Administration tab at the top or link in the navigation block is available to editing
teachers in the course so they can delete page versions or selected pages. Clicking the “list
all” button will list available pages to delete. The first page of the wiki cannot be deleted.

Deleting pages
Teachers and other users with the mod/wiki:managewiki capability can delete any page
or page version, with the exception of the first page, via the Administration link in the
navigation block or the Administration tab. See the section Administration above.

Mark-up language
You miss all the formatting you know from other moodle activities? That’s
because the wiki-type of your wiki is e.g. nwiki. See Nwiki mark-up

Why use a wiki?
Wikis are a simple, flexible tool for collaboration. They can be used for everything from simple lists of web
links to building entire encyclopaedias. As an example, Wikipedia is the largest wiki in the world. In your
own class it’s important to have a plan for your wiki so students know how it fits in with their learning. If
it’s a individual wiki, will they be graded? Is it simply a staging area for group work that will be submitted
as assignments later? Will you let the students be completely responsible for the work? How will you deal
with offensive content? The great advantage of a wiki is that all edits are clearly visible and reversible.
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Conditional activity
and Restricting
access
CONDITIONAL ACTIVITIES
Conditional activities enable teachers to restrict the availability of any activity or even a course
section (in Moodle 2.3 onwards) according to certain conditions such as dates, grade obtained,
or activity completion. When it is enabled by the administrator, a “Restrict access” setting appears
in the settings of activities or resources and also when editing a course section.

Enabling the use of conditional activities

••

To use conditional activities, the feature must be enabled by an administrator by checking
the enable availability box in Settings > Site administration > Advanced features.

A restrict access section will then appear for teachers on the edit activity page.

Restricting access
The restrict access section asks for the conditions
when the activity (or resource) should be visible.
This can be based upon dates, and/or score ranges
of other activities and/or if other activities are
considered completed (see Activity completion).
Note that ALL access restrictions (date, grade condition,
activity completion condition) have to be met in order
for the activity to be made available and that access
may be restricted to an actual time and not just a date.
Generally access is prevented before the conditions
are met, however if ‘Allow access until’ is enabled, then access is prevented after the specified date.
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Restricting access to course sections
It is possible to restrict access to activities within a whole course section by
specifying the conditions in the settings for that particular section.

Restricting access by user profile fields
It is possible to restrict access to activities based on a custom user profile field.

You can select a field type, condition and name.

Grade condition
You can specify a condition on any grade in the course: the full course grade, the grade for any activity,
or a custom grade that you create manually. You can enter either a minimum value (at least percentage),
or a maximum value (less than percentage), or both, or neither. The activity will only appear if the
student has a value for the specified grade, and if it falls within any specified number range. You can add
more than one grade condition. All conditions must be met in order for the activity to appear.
••The range numbers can be fractional (with up to five decimal places) if necessary.
••Be careful with the maximum value; if the maximum is 7, a student who scores exactly 7 will not see the activity. You
could set it to 7.01 if you really wanted to include 7.
••If creating several different activities that appear according to grade ranges, use the same number for the maximum
of one activity, and the minimum of the next. For example, you might create one activity with a maximum of 7 and
another with a minimum of 7. The first would appear to everyone scoring between 0 and 6.99999, and the second
would appear to everyone scoring 7.00000 to 10. This guarantees that everyone with a grade will see one or other.

Removing a grade condition
To remove a grade condition, set the assessment name to ‘none’ and remove the range number values..
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Activity logs
and Reports
COURSE ACTIVITY LOG
A teacher or non-editing teacher can generate a log of activity in the course
in Administration> Course administration>Reports > Logs.
To generate a log, select any combination of group, student, date, activity
and actions, then click the “Get these logs” button.
You can see what pages a student
accessed, the time and date they
accessed it, the IP address they
came from, and their actions
(view, add, update, delete).
You can choose to display the
logs on a page or download them
in text, ODS or Excel format.

••

Note: The log report page contains active links enabling you to access a student’s profile page or a
particular page that the student viewed. The IP address link provides an estimate of a student’s location.

COURSE ACTIVITY REPORT
A course activity report shows the number of views for each activity and resource (and
any related blog entries). Managers, teachers and non-editing teachers can obtain a report
from Administration > Course administration > Reports > Activity report.

An activity report is computed from the course’s start date (in the course settings).

••

Note: The length of time that the activity report covers is determined by the site administrator using the
‘loglifetime’ setting in Administration > Site administration > Courses > Backups > General backup defaults.
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COURSE PARTICIPATION REPORT
A manager, teacher or non-editing teacher can generate a participation report for a particular course
activity from Administration > Course administration > Reports > Course participation.

••

Notes:

In a course participation report, the ‘Activity’ selector will offer all the resources and activities contained in a course.
An on-screen definition is given for View and Post for the selected Activity type. For example:
Forum View: View Discussion, Search, Forum, Forums, Subscribers
Forum Post: Add Discussion, Add Post, Delete Discussion, Delete Post, Move Discussion, Prune Post, Update Post
An extremely useful feature of the participation report is the option to send a message to all students who have
not completed a certain action. Other options with selected users are to add a note or extend enrolment.

••

Note: If a forum post is
moved, the participation report will
show incorrect results for the affected
forums. For example: a student posted
in forum A and the post was moved to
forum B. The course participation report
will list the student as having posted in
forum A, but it will not show the student
as having made a post in forum B.

ACTIVITY COMPLETION REPORT

Managers, teachers and non-editing teachers can view Activity Completion information
from Administration> Course administration> Reports > Activity completion.
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PARTICIPANTS’ COURSE ACTIVITY LOGS
Managers, teachers and non-editing teachers can view participants’
Course Activity logs from Navigation> Current course> Participants.

Use the First name
/ Surname filters to
find a participant,
or scroll down
the list. Click
the participant’s
name to open
the profile.

Then, in Administration> Profile settings for (name of participant)
click Activity reports and choose the report you want to view.
•• Today’s logs
•• All logs
•• Outline report (most useful, quick glance reference – in course sections, what
was viewed, how often, most recent view, along with grades for completed
activities)
•• Complete report (includes contributions to forums, chat and glossaries).
•• Statistics – when enabled by administrator.
•• Grade
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Backup and Restore
a course
A course can be saved with some or all of its parts by using the course backup. Typically, the site administrator
will set a schedule of automated course backups for the whole site. A teacher with editing privileges can
create a backup or download an existing backup for safe keeping, or for use on another Moodle site.

SOME USES OF BACKUP AND RESTORE
A teacher can use the backup and restore processes in many ways:
••Duplicating courses or specific activities in one course to another course (similar to Import)
••Updating a production Moodle site course, with material from a localhost site course
••Transferring a course to a new Moodle site.
••Creating a blank activity, save just that activity and then restore it to the course or another course one or more times.

COURSE BACKUP
••

To backup a course, go to Administration> Course administration > Backup

••
In the initial settings, select activities, blocks, filters and other items as required then click the
Next button.

••

Only those users with administrator or manager permissions can choose whether
to include users, anonymize user information, or include user role assignments, user
files, comments, user completion details, course logs and grade history in the backup.
User data includes such information as forum posts, glossary entries and so on. It
also includes the relevant user accounts as well, in order that data consistency can be maintained
when the backup is restored on a different Moodle site. Unfortunately, in the wrong hands, this
feature can also cause a privacy leak and possible exploitation of the whole original site.

••
••

Note: Users with the teacher role are not able to backup user information belonging to
activities, so there will be a red cross and padlock next to any user information.
Tip: Glossary and database activity entries can easily be moved to a different course using
the Export and Import entries feature without needing to backup user data.
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•• Schema settings - Select/deselect specific items to include in backup then click
the Next button
•• Confirmation and review - Check that everything is as required, using the
Previous button if necessary, otherwise click the ‘Perform backup’ button
•• Complete - Click the Continue button
A backup file (with distinctive .mbz extension to avoid confusion
with .zip files) is then saved in the course backup area.

Backup and restore from 1.9 to 2
Courses created in 1.9 can be backed up and then restored into a 2.1 Moodle or later but blocks are
not currently restored and nor is user data (such as forum posts, grades, submissions etc)

••

Tip: Have you apparently lost content after a restore in Moodle 2.0? Look for
the topic headings that say “Orphaned activities”. The go to course settings and
increase the number of topic sections and things will return to normal.

Backup individual activities
It is possible to make a copy or backup of individual activities in a Moodle course and then re-use these
activities in a different Moodle site or in a different course on the same Moodle. (Note that if you wish
to re-use activities within the same Moodle it might be simpler to use the Import function.

•• To make a backup of an individual activity, ensure you are logged in with editing rights, as a
teacher for example. Click on the activity you wish to backup. The settings block to the side will
have a link Backup as shown in the screenshot:

••

In the next screen, check/tick the type of item you wish to backup - in this case, just Activities

•• Click Next and on the next screen, check the activity you wish to backup:
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••Click Next and on the next screen, if you wish, rename the filename (keeping its .mbz extension), check you have
included the correct activity and click Perform backup. You will get a message saying the backup file was successfully
created.
••Click Continue and you will find your backup in the User Private backup area of the next screen:

You can download your file from here and then restore it to a course in another
Moodle site. See Activity restore for information on how to do this.

••

Note: For security reasons, those with the teacher role are not able to backup user information
belonging to activities, so there will be a red cross and padlock next to any user information.

COURSE RESTORE
A course backup file (.mbz) may be restored from within any existing course for which you have permission.
During the restore process, you will be given the option to restore as a new course or into an existing course.

•• Go to Administration > Course administration > Restore (if you have an empty
course to restore into.)
•• Upload the backup file, or choose a file in the course backup area or in the user
private backup area, and click Restore

••Confirm - Check that everything is as required then click the Continue button
••Destination - Choose whether the course should be restored as a new course or into an existing course then click the
Continue button
••Settings - Select activities, blocks, filters and possibly other items as required then click the Next button
••Schema - Select/deselect specific items and amend the course name, short name and start date if necessary then
click the Next button
••Review - Check that everything is as required, using the Previous button if necessary, then click the ‘Perform restore’
button
••Complete - Click the continue button
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Just ask us...

:)

HowToMoodle
This Course Creator Essential manual is compiled
from selected content from the Moodle
community documentation site at http://
docs.moodle.org and aims to be a convenient
companion to support your work with Moodle.
If you find this resource useful feel free to
distribute it in electronic or printed formats.
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